summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2017-12-10 19:35:37 -0200
committerRafael Fontenelle2017-12-10 19:35:37 -0200
commit3adf955ca96de422fa3ac002662e5698aebe9742 (patch)
tree0f1a76a6edd8a0edf68d49f2a09754aabb65a79a
parentcda2e561ab801c34329a090b0fd5b799f31ec915 (diff)
downloadaur-3adf955ca96de422fa3ac002662e5698aebe9742.tar.gz
Drop i686 support
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 27 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 959afe94098b..97b6c4eb9490 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,25 @@
# Generated by mksrcinfo v8
-# Wed Nov 23 02:31:40 UTC 2016
+# Sun Dec 10 21:35:28 UTC 2017
pkgbase = gwclient
pkgdesc = Novell Groupwise 8 Client for Linux
pkgver = 8.0.2.90840
pkgrel = 9
url = http://gwclient.provo.novell.com/
- arch = i686
arch = x86_64
license = custom
- makedepends = prelink
depends = libgnome
depends = gtk-update-icon-cache
depends = desktop-file-utils
depends = shared-mime-info
+ depends = lib32-glibc
+ depends = lib32-libstdc++5
+ depends = bin32-jre6
+ depends = lib32-libxrender
+ depends = lib32-libxt
source = https://gwclient.innerweb.novell.com/client/gw802linuxclientmulti.tar.gz
source = groupwise.sh.in
md5sums = 16b1e563cc60b933ed2444e804ee7562
md5sums = 4bdde9dfc9c1b08bf2c335712ea7a8ad
- depends_i686 = glibc
- depends_i686 = libstdc++5
- depends_i686 = jre6
- depends_i686 = libxrender
- depends_i686 = libxt
- depends_x86_64 = lib32-glibc
- depends_x86_64 = lib32-libstdc++5
- depends_x86_64 = bin32-jre6
- depends_x86_64 = lib32-libxrender
- depends_x86_64 = lib32-libxt
pkgname = gwclient
diff --git a/PKGBUILD b/PKGBUILD
index 9170831338bd..cbfc7fa8efcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,29 +11,32 @@ pkgver=${_version}.${_build}
pkgrel=9
pkgdesc="Novell Groupwise 8 Client for Linux"
url="http://gwclient.provo.novell.com/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=(custom)
-depends=('libgnome' 'gtk-update-icon-cache' 'desktop-file-utils' 'shared-mime-info')
-depends_i686=('glibc' 'libstdc++5' 'jre6' 'libxrender' 'libxt')
-depends_x86_64=('lib32-glibc' 'lib32-libstdc++5' 'bin32-jre6' 'lib32-libxrender' 'lib32-libxt')
-makedepends=('prelink')
-source=(https://gwclient.innerweb.novell.com/client/gw802linuxclientmulti.tar.gz
+depends=('libgnome' 'gtk-update-icon-cache' 'desktop-file-utils' 'shared-mime-info'
+ 'lib32-glibc' 'lib32-libstdc++5' 'bin32-jre6' 'lib32-libxrender' 'lib32-libxt')
+source=("https://gwclient.innerweb.novell.com/client/gw802linuxclientmulti.tar.gz"
groupwise.sh.in)
md5sums=('16b1e563cc60b933ed2444e804ee7562'
'4bdde9dfc9c1b08bf2c335712ea7a8ad')
+prepare() {
+ mkdir $pkgname-$pkgver || true
+ cd $pkgname-$pkgver
+
+ # Excluding filters save 51MB from java/ and 92M from help/.
+ # Remove exclude filter of help/ in order to have help files in the pk
+ msg2 " Extracting tarball and removing embedded JRE and help files"
+ bsdtar xf "$srcdir/gw${_version}-${_build}_client_linux_multi/novell-groupwise-client-${_version}-${_build}.i586.rpm" \
+ --exclude=java --exclude=help
+}
+
package() {
# reduce the number of chars by setting variables
GWDIR=opt/novell/groupwise/client
- if [ $CARCH == x86_64 ]; then
- JAVA_RUNTIME=/usr/lib32/jvm/default-runtime/lib/i386/client/
- MOZ_PLUGIN_PATH=/usr/lib32/mozilla
- GWLIBDIR=/usr/lib32/gwclient
- elif [ $CARCH == i686 ]; then
- JAVA_RUNTIME=/usr/lib/jvm/default-runtime/lib/i386/client/
- MOZ_PLUGIN_PATH=/usr/lib/mozilla
- GWLIBDIR=/usr/lib/gwclient
- fi
+ JAVA_RUNTIME=/usr/lib/jvm/default-runtime/lib/i386/client/
+ MOZ_PLUGIN_PATH=/usr/lib/mozilla
+ GWLIBDIR=/usr/lib/gwclient
# prepare system folders and symlinks
install -d "$pkgdir"/opt/novell/groupwise/bin \
@@ -42,21 +45,10 @@ package() {
"$pkgdir"/usr/share/applications/ \
"$pkgdir"/usr/share/icons/hicolor/48x48/apps/
- [ -d "$pkgname-$pkgver" ] && rm -rf "$pkgname-$pkgver"
- mkdir "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
- msg2 " Extracting tarball and removing embedded JRE and help files"
- # The exclude filters save 51MB from java/ and 92M from help/.
- # Remove exclude filter of help/ in order to have help files in the pkg
- bsdtar xf "$srcdir/gw${_version}-${_build}_client_linux_multi/novell-groupwise-client-${_version}-${_build}.i586.rpm" \
- --exclude=java --exclude=help
-
- msg2 " Fixing lib's stack guard"
- # fix this lib's stack guard (eliminate warning in the console)
- execstack -c $GWDIR/lib/libgwapijni.so.1
+ cd "$pkgname-$pkgver"
- msg2 " Installing /opt, binaries and libraries"
+ msg2 " Installing /opt, binaries and libraries"
mv $GWDIR/bin/groupwise-bin "$pkgdir"/opt/novell/groupwise/bin
ln -s $GWLIBDIR "$pkgdir"/opt/novell/groupwise/lib
@@ -70,7 +62,7 @@ package() {
# install libraries
mv $GWDIR/lib/* "$pkgdir"/$GWLIBDIR
- msg2 " Installing icons and desktop files"
+ msg2 " Installing icons and desktop files"
mv $GWDIR/gwclient.desktop "$pkgdir"/usr/share/applications/
mv $GWDIR/gwclient.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/