summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Ferreira2015-06-20 11:58:22 -0300
committerRafael Ferreira2015-06-20 11:58:22 -0300
commitb4ce17db3f1c9f997a9bf0481eef9fb49eeb67e4 (patch)
treef13a6fa767dab9cea1e3f194fa41c0fbb1ba969c
downloadaur-b4ce17db3f1c9f997a9bf0481eef9fb49eeb67e4.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD86
-rw-r--r--groupwise.sh.in6
-rw-r--r--gwclient.install15
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb1724b53a4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = gwclient
+ pkgdesc = Novell Groupwise 8 Client for Linux
+ pkgver = 8.0.2.90840
+ pkgrel = 8
+ url = http://gwclient.provo.novell.com/
+ install = gwclient.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ makedepends = prelink
+ depends = libgnome
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ source = https://gwclient.innerweb.novell.com/client/gw802linuxclientmulti.tar.gz
+ source = groupwise.sh.in
+ md5sums = 16b1e563cc60b933ed2444e804ee7562
+ md5sums = 4bdde9dfc9c1b08bf2c335712ea7a8ad
+ depends_i686 = glibc
+ depends_i686 = libstdc++5
+ depends_i686 = java-runtime
+ depends_i686 = libxrender
+ depends_i686 = libgnome
+ depends_i686 = libxt
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-libstdc++5
+ depends_x86_64 = java32-runtime
+ depends_x86_64 = lib32-libxrender
+ depends_x86_64 = lib32-libxt
+
+pkgname = gwclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e99686da6db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Contributor: Vryali <vryali at gmail dot com>
+# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+
+# NOTE: the source gw802linuxclientmulti is a ~200MB file,
+# but the package to be installed has only ~56MB.
+
+pkgname=gwclient
+_version=8.0.2
+_build=90840
+pkgver=${_version}.${_build}
+pkgrel=8
+pkgdesc="Novell Groupwise 8 Client for Linux"
+url="http://gwclient.provo.novell.com/"
+arch=('i686' 'x86_64')
+license=(custom)
+install=$pkgname.install
+depends=('libgnome' 'hicolor-icon-theme' 'desktop-file-utils')
+depends_i686=('glibc' 'libstdc++5' 'java-runtime' 'libxrender' 'libgnome' 'libxt')
+depends_x86_64=('lib32-glibc' 'lib32-libstdc++5' 'java32-runtime' 'lib32-libxrender' 'lib32-libxt')
+makedepends=('rpmextract' 'prelink')
+source=(https://gwclient.innerweb.novell.com/client/gw802linuxclientmulti.tar.gz
+ groupwise.sh.in)
+md5sums=('16b1e563cc60b933ed2444e804ee7562'
+ '4bdde9dfc9c1b08bf2c335712ea7a8ad')
+
+package() {
+ # reduce the number of chars by setting variables
+ GWDIR=opt/novell/groupwise/client
+ if [ $CARCH == x86_64 ]; then
+ JAVA_RUNTIME=/usr/lib32/jvm/default-runtime/lib/i386/client/
+ MOZ_PLUGIN_PATH=/usr/lib32/mozilla
+ GWLIBDIR=/usr/lib32/gwclient
+ elif [ $CARCH == i686 ]; then
+ JAVA_RUNTIME=/usr/lib/jvm/default-runtime/lib/i386/client/
+ MOZ_PLUGIN_PATH=/usr/lib/mozilla
+ GWLIBDIR=/usr/lib/gwclient
+ fi
+
+ # prepare system folders and symlinks
+ install -d "$pkgdir"/opt/novell/groupwise/bin \
+ "$pkgdir"/usr/bin/ \
+ "$pkgdir"/$GWLIBDIR \
+ "$pkgdir"/usr/share/applications/ \
+ "$pkgdir"/usr/share/icons/hicolor/48x48/apps/
+
+ msg2 " Extracting tarball and removing embedded JRE and help files"
+ [ -d "$pkgname-$pkgver" ] && rm -rf "$pkgname-$pkgver"
+ mkdir "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
+ ls "$srcdir/gw${_version}-${_build}_client_linux_multi/novell-groupwise-client-${_version}-${_build}.i586.rpm" | xargs rpmextract.sh
+
+ # remove/comment this line to NOT remove all Help files
+ # (it will increase the package size in ~90MB)
+ rm -rf $GWDIR/lib/help
+
+ # remove JRE; use distribution's JavaRE package instead
+ rm -rf $GWDIR/java
+
+ msg2 " Fixing lib's stack guard"
+ # fix this lib's stack guard (eliminate warning in the console)
+ execstack -c $GWDIR/lib/libgwapijni.so.1
+
+ msg2 " Installing /opt, binaries and libraries"
+ mv $GWDIR/bin/groupwise-bin "$pkgdir"/opt/novell/groupwise/bin
+ ln -s $GWLIBDIR "$pkgdir"/opt/novell/groupwise/lib
+
+ # install binaries
+ install -m755 "$srcdir"/groupwise.sh.in "$pkgdir"/usr/bin/groupwise
+ sed -i "$pkgdir"/usr/bin/groupwise \
+ -e "s#@JAVA_RUNTIME@#$JAVA_RUNTIME#" \
+ -e "s#@MOZ_PLUGIN_PATH@#$MOZ_PLUGIN_PATH#" \
+ -e "s#@GWLIBDIR@#$GWLIBDIR#"
+
+ # install libraries
+ mv $GWDIR/lib/* "$pkgdir"/$GWLIBDIR
+
+ msg2 " Installing icons and desktop files"
+ mv $GWDIR/gwclient.desktop "$pkgdir"/usr/share/applications/
+ mv $GWDIR/gwclient.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/
+
+ # fix Name and Exec and Icon paths in the desktop file
+ sed -i "$pkgdir"/usr/share/applications/gwclient.desktop \
+ -e 's/Name=.*/Name=Novell GroupWise/' \
+ -e 's/Exec=.*/Exec=groupwise/' \
+ -e 's/Icon=.*/Icon=gwclient.png/'
+}
diff --git a/groupwise.sh.in b/groupwise.sh.in
new file mode 100644
index 000000000000..7c217d210eb9
--- /dev/null
+++ b/groupwise.sh.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+export LD_LIBRARY_PATH=@GWLIBDIR@:@JAVA_RUNTIME@
+export MOZ_PLUGIN_PATH=@MOZ_PLUGIN_PATH@
+
+/opt/novell/groupwise/bin/groupwise-bin -wr=off "$@"
diff --git a/gwclient.install b/gwclient.install
new file mode 100644
index 000000000000..452cd42a7adc
--- /dev/null
+++ b/gwclient.install
@@ -0,0 +1,15 @@
+
+
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+ echo "Type 'groupwise' to start using the mail client."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}