summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-02-02 19:10:33 +0100
committerSophie Tauchert2019-02-02 19:10:33 +0100
commite4bf825893c4152deb2c5d4e94b5aabed9b482c1 (patch)
tree4bde23108a69e5e01932620e1a7f563843403df5
parentce1d2d7061401e0a526ee8e3e76e7db42063a1ad (diff)
downloadaur-e4bf825893c4152deb2c5d4e94b5aabed9b482c1.tar.gz
Update to v0.9.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 918a77d66c76..1e6f9bb99c66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gwe
pkgdesc = A system utility for controlling NVIDIA GPUs
- pkgver = 0.8.0
+ pkgver = 0.9.0
pkgrel = 1
url = https://gitlab.com/leinardi/gwe
arch = any
@@ -18,8 +18,10 @@ pkgbase = gwe
depends = python-requests
depends = python-rx
depends = python-xdg
- source = https://gitlab.com/leinardi/gwe/-/archive/0.8.0/gwe-0.8.0.tar.gz
- sha256sums = e5f73946ae4d6c6997cfc60f838e945a273dd690b4ea1291612ffc92ffd2debb
+ source = https://gitlab.com/leinardi/gwe/-/archive/0.9.0/gwe-0.9.0.tar.gz
+ source = https://github.com/leinardi/python-xlib/archive/67ef8a5b3951396752746d7e103500d098ec1bf1.tar.gz
+ sha256sums = bac956838702db1d367b449b8c8a70973c7204bca5d88098434124235eee5fba
+ sha256sums = 800e1c1b382dfb67aaac4c4d2565e5edd0851e9e49b2cb06bc17c354f2027abd
pkgname = gwe
diff --git a/PKGBUILD b/PKGBUILD
index d9ac00502bb8..e2ae21e63d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
pkgname=gwe
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="A system utility for controlling NVIDIA GPUs"
arch=('any')
@@ -10,8 +10,16 @@ license=('GPL3')
depends=('libdazzle' 'libappindicator3' 'python' 'python-cairo' 'python-gobject' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-requests' 'python-rx' 'python-xdg')
makedepends=('meson')
provides=()
-source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('e5f73946ae4d6c6997cfc60f838e945a273dd690b4ea1291612ffc92ffd2debb')
+_xlib_commit='67ef8a5b3951396752746d7e103500d098ec1bf1'
+source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "https://github.com/leinardi/python-xlib/archive/${_xlib_commit}.tar.gz")
+sha256sums=('bac956838702db1d367b449b8c8a70973c7204bca5d88098434124235eee5fba'
+ '800e1c1b382dfb67aaac4c4d2565e5edd0851e9e49b2cb06bc17c354f2027abd')
+
+prepare() {
+ rmdir "$pkgname-$pkgver/python-xlib"
+ ln -s "../python-xlib-${_xlib_commit}" "$pkgname-$pkgver/python-xlib"
+}
build() {
meson --prefix /usr --buildtype=plain "$pkgname-$pkgver" build