summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-01-30 22:50:17 +0100
committerSophie Tauchert2019-01-30 22:50:17 +0100
commite75959738e891fce7da25b5b88cffa1520613b89 (patch)
tree35c5ab22e9d438130d9b3656a2ac27bbcb9b6523
downloadaur-e75959738e891fce7da25b5b88cffa1520613b89.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD27
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d71e7161ef0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gwe
+ pkgdesc = A system utility for controlling NVIDIA GPUs
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://gitlab.com/leinardi/gwe
+ arch = any
+ license = GPL3
+ makedepends = meson
+ depends = libdazzle
+ depends = libappindicator3
+ depends = python
+ depends = python-cairo
+ depends = python-gobject
+ depends = python-injector
+ depends = python-matplotlib
+ depends = python-peewee
+ depends = python-py3nvml
+ depends = python-requests
+ depends = python-rx
+ depends = python-timeago
+ depends = python-xdg
+ source = https://gitlab.com/leinardi/gwe/-/archive/0.7.0/gwe-0.7.0.tar.gz
+ sha256sums = 02058831686eeca4329b539a0d617b2fcd92a568ca4b1a773cb34c230b15972a
+
+pkgname = gwe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea4602d59afd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+
+pkgname=gwe
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A system utility for controlling NVIDIA GPUs"
+arch=('any')
+url="https://gitlab.com/leinardi/gwe"
+license=('GPL3')
+depends=('libdazzle' 'libappindicator3' 'python' 'python-cairo' 'python-gobject' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-requests' 'python-rx' 'python-timeago' 'python-xdg')
+makedepends=('meson')
+provides=()
+source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('02058831686eeca4329b539a0d617b2fcd92a568ca4b1a773cb34c230b15972a')
+
+build() {
+ meson --prefix /usr --buildtype=plain "$pkgname-$pkgver" build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}