summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat Bakarov2015-06-10 18:57:46 +0600
committerAskhat Bakarov2015-06-10 18:57:46 +0600
commit4ae5e8787005aaf0c8b95830500baf7352e927ff (patch)
tree8498da4f38a2c21a990ab19fa0bc8eefaeacf4bf
downloadaur-4ae5e8787005aaf0c8b95830500baf7352e927ff.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD64
-rw-r--r--gwyddion.install22
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89a16e35a200
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = gwyddion
+ pkgdesc = A data visualization and processing tool for scanning probe miscroscopy (SPM, i.e. AFM, STM, MFM, SNOM/NSOM, ...) and profilometry, useful also for general image and 2D data analysis
+ pkgver = 2.41
+ pkgrel = 1
+ url = http://gwyddion.net/
+ install = gwyddion.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = gtk2
+ depends = pango
+ depends = cairo
+ depends = gtkglext
+ depends = desktop-file-utils
+ depends = python2
+ depends = pygtk
+ depends = hicolor-icon-theme
+ depends = openexr
+ depends = fftw
+ depends = libunique
+ optdepends = libxmu: for alternative "remote control" backend
+ optdepends = gconf: better GNOME and XFce integration (SPM file thumbnails)
+ optdepends = libxml2: SPML file support
+ optdepends = zlib: Matlab MAT5 file support
+ optdepends = perl: development of plug-in
+ optdepends = ruby: development of plug-in
+ optdepends = fpc: development of plug-in
+ optdepends = gtksourceview2: Pygwy console syntax highlighting
+ source = http://downloads.sourceforge.net/sourceforge/gwyddion/gwyddion-2.41.tar.xz
+ sha256sums = dcccba56231d6553ded5ba3613f70e4b71f4365e6482e65c69b4eea8bb4d8afa
+
+pkgname = gwyddion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a77336982690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# on the base of Gentoo gwyddion ebuild
+# http://packages.gentoo.org/package/sci-visualization/gwyddion
+
+pkgname=gwyddion
+pkgver=2.41
+pkgrel=1
+pkgdesc="A data visualization and processing tool for scanning probe miscroscopy (SPM, i.e. AFM, STM, MFM, SNOM/NSOM, ...) and profilometry, useful also for general image and 2D data analysis"
+#A modular program for SPM (scanning probe microscopy) and other 2D (height field) data visualization and analysis"
+url="http://gwyddion.net/"
+license=("GPL")
+arch=('i686' 'x86_64')
+depends=(gtk2 pango cairo gtkglext desktop-file-utils python2 pygtk
+ hicolor-icon-theme openexr fftw libunique)
+#depends=('freeglut' 'gtksourceview')
+makedepends=('pkgconfig')
+optdepends=('libxmu: for alternative "remote control" backend'
+ 'gconf: better GNOME and XFce integration (SPM file thumbnails)'
+ 'libxml2: SPML file support'
+ 'zlib: Matlab MAT5 file support'
+ 'perl: development of plug-in'
+ 'ruby: development of plug-in'
+ 'fpc: development of plug-in'
+ 'gtksourceview2: Pygwy console syntax highlighting')
+install=gwyddion.install
+source=(http://downloads.sourceforge.net/sourceforge/gwyddion/$pkgname-$pkgver.tar.xz)
+sha256sums=('dcccba56231d6553ded5ba3613f70e4b71f4365e6482e65c69b4eea8bb4d8afa')
+
+
+build() {
+ cd $pkgname-$pkgver
+
+# ./configure --prefix=/usr --disable-desktop-file-update \
+# --disable-rpath \
+# --enable-library-bloat \
+# --enable-plugin-proxy \
+# --disable-updater --disable-schemas-compile \
+
+
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib \
+ --disable-schemas-install \
+ PYTHON=python2
+ make PYTHON=python2
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 PYTHON=python2 install
+
+ install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
+
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain gwyddion ${pkgdir}/etc/gconf/schemas/*.schemas
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
+
+
+
diff --git a/gwyddion.install b/gwyddion.install
new file mode 100644
index 000000000000..05f59ae256c9
--- /dev/null
+++ b/gwyddion.install
@@ -0,0 +1,22 @@
+pkgname=gwyddion
+
+post_install() {
+ gconfpkg --install $pkgname
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ gconfpkg --uninstall $pkgname
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}