summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Sztandera2016-02-26 14:10:09 +0100
committerJakub Sztandera2016-02-26 14:10:09 +0100
commit359f6fa78b5e0bc4f87eb81553f905d132c612b9 (patch)
treed888dc2cbf7f29138d85c9e8141d46ffdf3a7d46
downloadaur-359f6fa78b5e0bc4f87eb81553f905d132c612b9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD47
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d842df6bcb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 26 13:09:34 UTC 2016
+pkgbase = gx
+ pkgdesc = Packaging tool built around the distributed, content addressed filesystem IPFS. It aims to be flexible, powerful and simple.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/whyrusleeping/gx
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = go
+ optdepends = gx-go: gx packaing module for go
+ source = git+https://github.com/whyrusleeping/gx.git
+ md5sums = SKIP
+
+pkgname = gx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd0746d4d5a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+gx
+gx-*
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cb740c7c1c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
+# vim: set expandtab ts=2 sw=2:
+
+pkgname=gx
+pkgver=0.3.0
+pkgrel=1
+epoch=
+pkgdesc="Packaging tool built around the distributed, content addressed filesystem IPFS. It aims to be flexible, powerful and simple."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/whyrusleeping/$pkgname"
+license=('MIT')
+makedepends=('go')
+optdepends=('gx-go: gx packaing module for go')
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver_DISABLED() {
+ # Renable after tags are placed in the repo.
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "$srcdir"/src/github.com/whyrusleeping/
+ ln -fs "$srcdir/$pkgname" "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+}
+
+build() {
+ # Required for go get
+ export GOPATH="$srcdir"
+ cd "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+
+ msg2 'Installing dependencies...'
+ go get -v
+
+ msg2 'Building binary...'
+ go install -v
+}
+
+package() {
+ msg2 'Packaging binary...'
+ install -Dm 755 bin/gx "${pkgdir}/usr/bin/gx"
+
+ msg2 'Packaging auxiliary files...'
+ cd "$pkgname"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}