summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg2020-03-25 20:21:25 +0100
committerJohannes Löthberg2020-03-25 20:21:25 +0100
commit4f969b511f35c4847524e4e9717321b7730adc1a (patch)
treeebb0410dde3690c1af513b5f275e27605833b8e6
parent965602d9710c0675331408312102866f6f88200e (diff)
downloadaur-4f969b511f35c4847524e4e9717321b7730adc1a.tar.gz
Drop from [community]
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 39 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8735be0e299..25b39c271c0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,15 @@
-# Generated by mksrcinfo v8
-# Tue Feb 27 11:23:16 UTC 2018
pkgbase = gx
- pkgdesc = Packaging tool built around the distributed, content addressed filesystem IPFS. It aims to be flexible, powerful and simple.
- pkgver = 0.12.1
- pkgrel = 1
+ pkgdesc = Packaging tool built around the distributed, content addressed filesystem IPFS
+ pkgver = 0.14.1
+ pkgrel = 4
url = https://github.com/whyrusleeping/gx
- arch = i686
arch = x86_64
- arch = armv7h
license = MIT
- depends = glibc
- optdepends = gx-go: gx packaging module for go
- source_i686 = https://ipfs.io/ipns/dist.ipfs.io/gx/v0.12.1/gx_v0.12.1_linux-386.tar.gz
- sha512sums_i686 = 5388716b3991fa5573a5334cf90b71ed934df1ecdbbb4691252d0afa0a310853bfef7461fc9efd9bc41c54d7a775cb82279c9563766319b85f33cffcff191fa7
- source_x86_64 = https://ipfs.io/ipns/dist.ipfs.io/gx/v0.12.1/gx_v0.12.1_linux-amd64.tar.gz
- sha512sums_x86_64 = 9f331cc0bcf46bbd00a2ae37b4dd540c71701be971292d6d8cc2c73c7de4fc714dcc01467719b18502dac3643fe1ba11ac0fc3797d9393b10c487ca34bcc558e
- source_armv7h = https://ipfs.io/ipns/dist.ipfs.io/gx/v0.12.1/gx_v0.12.1_linux-arm.tar.gz
- sha512sums_armv7h = bcf860f57a2cd9ef7c9f005a56038b3807de359a3e2edf7638ae1733ad88ced941bfdc6b52c19fdcc7e3b3905bea192d55acbc581b2f316fd7d47980fe435c3f
+ makedepends = git
+ makedepends = go-pie
+ optdepends = gx-go: gx packaing module for go
+ source = git+https://github.com/whyrusleeping/gx.git#tag=v0.14.1
+ md5sums = SKIP
pkgname = gx
diff --git a/PKGBUILD b/PKGBUILD
index 9f4c6e28916b..db696a87cdd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
-# Maintainer: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
-# vim: set expandtab ts=2 sw=2:
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
pkgname=gx
-pkgver=0.12.1
-pkgrel=1
+pkgver=0.14.1
+pkgrel=4
-pkgdesc="Packaging tool built around the distributed, content addressed filesystem IPFS. It aims to be flexible, powerful and simple."
-url="https://github.com/whyrusleeping/$pkgname"
-arch=('i686' 'x86_64' 'armv7h')
+pkgdesc="Packaging tool built around the distributed, content addressed filesystem IPFS"
+url="https://github.com/whyrusleeping/gx"
+arch=('x86_64')
license=('MIT')
-depends=('glibc')
-optdepends=('gx-go: gx packaging module for go')
-makedepends=()
+makedepends=('git' 'go-pie')
+optdepends=('gx-go: gx packaing module for go')
-_srcroot="https://ipfs.io/ipns/dist.ipfs.io"
-source_x86_64=("$_srcroot/$pkgname/v$pkgver/gx_v${pkgver}_linux-amd64.tar.gz")
-source_i686=("$_srcroot/$pkgname/v$pkgver/gx_v${pkgver}_linux-386.tar.gz")
-source_armv7h=("$_srcroot/$pkgname/v$pkgver/gx_v${pkgver}_linux-arm.tar.gz")
+source=("git+https://github.com/whyrusleeping/gx.git#tag=v$pkgver")
+md5sums=('SKIP')
-sha512sums_i686=('5388716b3991fa5573a5334cf90b71ed934df1ecdbbb4691252d0afa0a310853bfef7461fc9efd9bc41c54d7a775cb82279c9563766319b85f33cffcff191fa7')
-sha512sums_x86_64=('9f331cc0bcf46bbd00a2ae37b4dd540c71701be971292d6d8cc2c73c7de4fc714dcc01467719b18502dac3643fe1ba11ac0fc3797d9393b10c487ca34bcc558e')
-sha512sums_armv7h=('bcf860f57a2cd9ef7c9f005a56038b3807de359a3e2edf7638ae1733ad88ced941bfdc6b52c19fdcc7e3b3905bea192d55acbc581b2f316fd7d47980fe435c3f')
+prepare() {
+ mkdir -p "$srcdir"/src/github.com/whyrusleeping/
+ ln -fs "$srcdir/gx" "$srcdir"/src/github.com/whyrusleeping/gx
+}
+
+build() {
+ # Required for go get
+ export GOPATH="$srcdir"
+ export GOBIN="$GOPATH/bin"
+ cd "$srcdir"/src/github.com/whyrusleeping/gx
+
+ go get -v
+ go install \
+ -gcflags "all=-trimpath=$GOPATH" \
+ -asmflags "all=-trimpath=$GOPATH" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v
+}
package() {
- install -Dm 755 ${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 bin/gx "$pkgdir/usr/bin/gx"
+ install -Dm 644 gx/LICENSE "$pkgdir/usr/share/licenses/gx/LICENSE"
}