summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Sztandera2016-03-01 00:06:12 +0100
committerJakub Sztandera2016-03-01 00:06:12 +0100
commitbc8b6b8a7238c8801625fc214e1fa73d6b4a4b62 (patch)
treefe99791df9b3e624f9523721b05a9925f44cf5dc
parent6fd2c03bd565b7c8f4e47e17efc475ada6598ba7 (diff)
downloadaur-bc8b6b8a7238c8801625fc214e1fa73d6b4a4b62.tar.gz
Use tags for versions, depend on gx, update version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc7dcf4ea748..ea879b1eeae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 26 13:21:33 UTC 2016
+# Mon Feb 29 23:05:30 UTC 2016
pkgbase = gx-go
pkgdesc = A tool to use with the gx package manager for packages written in go.
- pkgver = 0.2.0
+ pkgver = 0.3.0.r0.g68d91f3
pkgrel = 1
url = https://github.com/whyrusleeping/gx-go
arch = i686
@@ -11,6 +11,7 @@ pkgbase = gx-go
license = MIT
makedepends = git
makedepends = go
+ depends = gx
source = git+https://github.com/whyrusleeping/gx-go.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 30a6dcf8c113..ead8afe57b53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
# vim: set expandtab ts=2 sw=2:
pkgname=gx-go
-pkgver=0.2.0
+pkgver=0.3.0.r0.g68d91f3
pkgrel=1
epoch=
pkgdesc="A tool to use with the gx package manager for packages written in go."
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/whyrusleeping/$pkgname"
license=('MIT')
+depends=('gx')
makedepends=('git' 'go')
source=("git+${url}.git")
md5sums=('SKIP')
-pkgver_DISABLED() {
+pkgver() {
# Renable after tags are placed in the repo.
cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'