summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Sztandera2017-06-04 17:49:25 +0200
committerJakub Sztandera2017-06-04 17:51:28 +0200
commit4d69aed466fc9a96e1df9bd9f7e2d69e671f7c2a (patch)
tree4c447596bcce1a45d574e51b74dca0f9f051c6d5
parent0a6fcbf90556756859e3bd20bbb726898c09f249 (diff)
downloadaur-gx-go-git.tar.gz
Create git version of package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d16134457628..72ae27a9611e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Aug 24 21:04:57 UTC 2016
-pkgbase = gx-go
+# Sun Jun 4 15:51:27 UTC 2017
+pkgbase = gx-go-git
pkgdesc = A tool to use with the gx package manager for packages written in go.
- pkgver = 1.3.0.r0.g3cbfcbb
+ pkgver = latest
pkgrel = 1
url = https://github.com/whyrusleeping/gx-go
arch = i686
@@ -12,8 +12,9 @@ pkgbase = gx-go
makedepends = git
makedepends = go
depends = gx
+ conflicts = gx-go
source = git+https://github.com/whyrusleeping/gx-go.git
md5sums = SKIP
-pkgname = gx-go
+pkgname = gx-go-git
diff --git a/PKGBUILD b/PKGBUILD
index 11df77aa28af..afa8bc5e5165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,37 @@
# Maintainer: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
# vim: set expandtab ts=2 sw=2:
-pkgname=gx-go
-pkgver=1.3.0.r0.g3cbfcbb
+_pkgname=gx-go
+pkgname=$_pkgname-git
+pkgver=latest
pkgrel=1
epoch=
pkgdesc="A tool to use with the gx package manager for packages written in go."
arch=('i686' 'x86_64' 'armv7h')
-url="https://github.com/whyrusleeping/$pkgname"
+url="https://github.com/whyrusleeping/$_pkgname"
license=('MIT')
depends=('gx')
+conflicts=('gx-go')
makedepends=('git' 'go')
source=("git+${url}.git")
md5sums=('SKIP')
pkgver() {
# Renable after tags are placed in the repo.
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
mkdir -p "$srcdir"/src/github.com/whyrusleeping/
- ln -fs "$srcdir/$pkgname" "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+ ln -fs "$srcdir/$_pkgname" "$srcdir"/src/github.com/whyrusleeping/"$_pkgname"
}
build() {
# Required for go get
export GOPATH="$srcdir"
export GOBIN="$GOPATH/bin"
- cd "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+ cd "$srcdir"/src/github.com/whyrusleeping/"$_pkgname"
msg2 'Installing dependencies...'
go get -v
@@ -43,6 +45,6 @@ package() {
install -Dm 755 bin/gx-go "${pkgdir}/usr/bin/gx-go"
msg2 'Packaging auxiliary files...'
- cd "$pkgname"
+ cd "$_pkgname"
install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}