summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2022-12-18 15:40:57 +0300
committerkyak2022-12-18 15:40:57 +0300
commitb8db33dd4c6d49d8fe6c05f29fc29c1b8ccebd5e (patch)
treecd2ef46e2aca3aa11c2545a1526eafc4b629f56a
downloadaur-b8db33dd4c6d49d8fe6c05f29fc29c1b8ccebd5e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47253d2f4f0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gxkb-ru-by-flags
+ pkgdesc = X11 keyboard indicator and switcher with Russian and Belarusian flags included
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = https://zen-tools.github.io/gxkb
+ arch = x86_64
+ license = GPL2
+ depends = libxklavier
+ depends = libwnck3
+ depends = gtk3
+ conflicts = gxkb
+ source = https://github.com/kyak/gxkb-ru-by-flags/archive/87b9dfe917be7ba6f7aae8ae73f781f94833d517.tar.gz
+ sha256sums = 2c8a516f78a2c5c4fcb66c327c1be0ec020fecc79e1305129717f05a66272ede
+
+pkgname = gxkb-ru-by-flags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f0a621835b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer: A.T.W.A. <arch.atwa@gmail.com>
+
+pkgname=gxkb-ru-by-flags
+pkgver=0.9.4
+pkgrel=1
+commit=87b9dfe917be7ba6f7aae8ae73f781f94833d517
+pkgdesc="X11 keyboard indicator and switcher with Russian and Belarusian flags included"
+arch=('x86_64')
+url="https://zen-tools.github.io/gxkb"
+license=('GPL2')
+depends=('libxklavier' 'libwnck3' 'gtk3')
+conflicts=('gxkb')
+source=("https://github.com/kyak/${pkgname}/archive/${commit}.tar.gz")
+sha256sums=('2c8a516f78a2c5c4fcb66c327c1be0ec020fecc79e1305129717f05a66272ede')
+
+build() {
+ cd "${srcdir}/${pkgname}-${commit}"
+ CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+ ./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${commit}"
+ make DESTDIR="${pkgdir}" install
+}