diff options
author | FabioLolix | 2024-07-13 10:53:21 +0200 |
---|---|---|
committer | FabioLolix | 2024-07-13 10:53:21 +0200 |
commit | e82f511d295201179c3ea27ea460b933b645da63 (patch) | |
tree | 5163ffe16514ea5add0e51ca7921033d50427a70 | |
parent | bf0b11cc17aa5223f14b57e7688c351b9c2b7256 (diff) | |
download | aur-e82f511d295201179c3ea27ea460b933b645da63.tar.gz |
upload
-rw-r--r-- | .SRCINFO | 12 | ||||
-rw-r--r-- | .gitignore | 7 | ||||
-rw-r--r-- | PKGBUILD | 45 |
3 files changed, 31 insertions, 33 deletions
@@ -1,22 +1,20 @@ -# Generated by mksrcinfo v8 -# Tue Oct 25 18:47:47 UTC 2016 pkgbase = gxml-git - pkgdesc = GObject XML and Serialization API - pkgver = 0.12.0 + pkgdesc = GObject-based XML parser and writer library + pkgver = 0.20.3.r18.g13c93b4 pkgrel = 1 url = https://wiki.gnome.org/GXml - arch = i686 arch = x86_64 license = LGPL + makedepends = git makedepends = gobject-introspection + makedepends = meson makedepends = vala depends = glib2 depends = libgee depends = libxml2 provides = gxml conflicts = gxml - source = git+https://git.gnome.org/browse/gxml#commit=a0b55b0fbae50359a361bff4c7ec49f975b2fa90 + source = git+https://gitlab.gnome.org/GNOME/gxml.git#branch=gxml-0.20 sha256sums = SKIP pkgname = gxml-git - diff --git a/.gitignore b/.gitignore new file mode 100644 index 000000000000..4dab8d6386e3 --- /dev/null +++ b/.gitignore @@ -0,0 +1,7 @@ +# Ignore everything +* + +# But not these files... +!.gitignore +!PKGBUILD +!.SRCINFO @@ -1,43 +1,36 @@ -# $Id$ -# Maintainer: Adria Arrufat <adria.arrufat+AUR@protonmail.ch> +# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix +# Contributor: Fernando Fernández <fernando at softwareperonista dot com dot ar> +# Contributor: Mark Wagie <mark dot wagie at tutanota dot com> +# Contributor: Balló György +# Contributor: Artem Vorotnikov <artem at vorotnikov dot me> pkgname=gxml-git -pkgver=0.12.0 +pkgver=0.20.3.r18.g13c93b4 pkgrel=1 -pkgdesc="GObject XML and Serialization API" -arch=('i686' 'x86_64') -license=('LGPL') -depends=('glib2' 'libgee' 'libxml2') -provides=(${pkgname/-git}) -conflicts=(${pkgname/-git}) -makedepends=('gobject-introspection' 'vala') +pkgdesc="GObject-based XML parser and writer library" +arch=(x86_64) url="https://wiki.gnome.org/GXml" -_commit="a0b55b0fbae50359a361bff4c7ec49f975b2fa90" -source=("git+https://git.gnome.org/browse/gxml#commit=${_commit}") +license=(LGPL) +depends=(glib2 libgee libxml2) +makedepends=(git gobject-introspection meson vala) +provides=(gxml) +conflicts=(gxml) +source=("git+https://gitlab.gnome.org/GNOME/gxml.git#branch=gxml-0.20") sha256sums=('SKIP') pkgver() { - cd ${pkgname/-git} - git describe --tags | sed 's/-/+/g' -} - -prepare() { - cd ${pkgname/-git} - NOCONFIGURE=1 ./autogen.sh + git -C gxml describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } build() { - cd ${pkgname/-git} - ./configure --prefix=/usr --enable-vapigen --enable-docs - make + arch-meson gxml build + meson compile -C build } check() { - cd ${pkgname/-git} - make check + meson test -C build --print-errorlogs } package() { - cd ${pkgname/-git} - make DESTDIR="$pkgdir" install + DESTDIR="$pkgdir" meson install -C build } |