summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGimmeapill2017-01-16 23:11:57 +0100
committerGimmeapill2017-01-16 23:11:57 +0100
commit9fa26556ed2f1b1b8231223b1afcb28715d2d68c (patch)
treebad813e67e296978c5176473a90165e7d3167741
downloadaur-9fa26556ed2f1b1b8231223b1afcb28715d2d68c.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fedad0892623
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Jan 16 22:08:16 UTC 2017
+pkgbase = gxplugins-lv2-git
+ pkgdesc = A set of extra lv2 plugins from the guitarix project.
+ pkgver = r4.aa71176
+ pkgrel = 1
+ url = https://github.com/brummer10/GxPlugins.lv2
+ arch = i686
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL3
+ makedepends = git
+ makedepends = lv2
+ makedepends = libxext
+ makedepends = freetype2
+ depends = libsndfile
+ depends = gtk2
+ provides = gxplugins-lv2
+ conflicts = gxplugins-lv2
+ source = gxplugins-lv2::git://github.com/brummer10/GxPlugins.lv2
+ md5sums = SKIP
+
+pkgname = gxplugins-lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67f9f1fb0f60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
+
+pkgname=gxplugins-lv2-git
+pkgver=r4.aa71176
+pkgrel=1
+pkgdesc="A set of extra lv2 plugins from the guitarix project."
+arch=('i686' 'x86_64')
+url="https://github.com/brummer10/GxPlugins.lv2"
+license=('GPL3')
+groups=('lv2-plugins')
+depends=('libsndfile' 'gtk2')
+makedepends=('git' 'lv2' 'libxext' 'freetype2')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}" "gx-lv2-git")
+source=("${pkgname%-*}"::'git://github.com/brummer10/GxPlugins.lv2')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-*}"
+ git submodule init
+ git submodule update
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ make DESTDIR="$pkgdir/" install PREFIX=/usr
+}
+