summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoxore2022-08-16 19:18:28 +0200
committerGoxore2022-08-16 19:18:28 +0200
commita2d8fbacd5513377ee737beaccc274d4516f2737 (patch)
tree1846d11430bfd228f6c0349174c8637da969d794
downloadaur-a2d8fbacd5513377ee737beaccc274d4516f2737.tar.gz
Innitial push.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f26ac08636d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gxrfetch-git
+ pkgdesc = A simple and customizable fetch program written in rust.
+ pkgver = 0.8.1.r31.f9e1579
+ pkgrel = 1
+ url = https://github.com/Goxore/gxrfetch
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL-3.0
+ makedepends = rust
+ makedepends = cargo
+ provides = gxrfetch
+ source = git+https://github.com/Goxore/gxrfetch
+ md5sums = SKIP
+
+pkgname = gxrfetch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb81c670d0dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Goxore <ggooxxoorree@gmail.com>
+pkgname=gxrfetch-git
+pkgver=0.8.1.r31.f9e1579
+pkgrel=1
+epoch=
+pkgdesc="A simple and customizable fetch program written in rust."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/Goxore/gxrfetch"
+license=('GPL-3.0')
+groups=()
+depends=()
+makedepends=('rust' 'cargo')
+checkdepends=()
+optdepends=()
+provides=(gxrfetch)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver(){
+ cd "${_pkgname}"
+ printf "0.8.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ return 0
+}
+
+package() {
+ #cargo install --root="$pkgdir" gxrfetch
+ cargo install --root="$pkgdir/opt" gxrfetch
+}