summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRutger Broekhoff2021-05-21 12:05:07 +0200
committerRutger Broekhoff2021-05-21 12:05:07 +0200
commit1e11b8ea17933eb6d023ff291659480817179590 (patch)
tree1933074f1b6d9bc6c0e3e0348dd2ee590a5349ab
downloadaur-1e11b8ea17933eb6d023ff291659480817179590.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD30
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c70d50868059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gyro-bin
+ pkgdesc = A Zig package manager with an index, build runner, and build dependencies
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/mattnite/gyro
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = MIT
+ provides = gyro
+ source = LICENSE
+ sha256sums = e8b7547024443b2fae2609708ffd1680a8f1973214f1523419fe91bd52aa8552
+ source_aarch64 = gyro-bin-0.2.3.tar.gz::https://github.com/mattnite/gyro/releases/download/0.2.3/gyro-0.2.3-linux-aarch64.tar.gz
+ sha256sums_aarch64 = a1cdcfa43bf558ddd4296a61d2f29948cd5c26865d5e24082b15702e10a8e8bb
+ source_i686 = gyro-bin-0.2.3.tar.gz::https://github.com/mattnite/gyro/releases/download/0.2.3/gyro-0.2.3-linux-i386.tar.gz
+ sha256sums_i686 = d34589466b657965c1384f4264b311015bcedff26b5deb926f39472ac7e35bd8
+ source_x86_64 = gyro-bin-0.2.3.tar.gz::https://github.com/mattnite/gyro/releases/download/0.2.3/gyro-0.2.3-linux-x86_64.tar.gz
+ sha256sums_x86_64 = 87fb8e9a769a6486c42ff69e8977daeb7c20f9f97f7e47fe81fb8de1113e26ac
+
+pkgname = gyro-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c7531935f703
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Matthew Knight
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f71b87a580d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Rutger Broekhoff <rutger@viasalix.nl>
+
+pkgname='gyro-bin'
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="A Zig package manager with an index, build runner, and build dependencies"
+arch=('aarch64' 'i686' 'x86_64')
+url="https://github.com/mattnite/gyro"
+license=('MIT')
+provides=('gyro')
+
+source=(LICENSE)
+source_aarch64=("${pkgname}-${pkgver}.tar.gz::https://github.com/mattnite/gyro/releases/download/${pkgver}/gyro-${pkgver}-linux-aarch64.tar.gz")
+source_i686=("${pkgname}-${pkgver}.tar.gz::https://github.com/mattnite/gyro/releases/download/${pkgver}/gyro-${pkgver}-linux-i386.tar.gz")
+source_x86_64=("${pkgname}-${pkgver}.tar.gz::https://github.com/mattnite/gyro/releases/download/${pkgver}/gyro-${pkgver}-linux-x86_64.tar.gz")
+sha256sums=('e8b7547024443b2fae2609708ffd1680a8f1973214f1523419fe91bd52aa8552')
+sha256sums_aarch64=('a1cdcfa43bf558ddd4296a61d2f29948cd5c26865d5e24082b15702e10a8e8bb')
+sha256sums_i686=('d34589466b657965c1384f4264b311015bcedff26b5deb926f39472ac7e35bd8')
+sha256sums_x86_64=('87fb8e9a769a6486c42ff69e8977daeb7c20f9f97f7e47fe81fb8de1113e26ac')
+
+package() {
+ local gyro_arch="$(get_pkg_arch)"
+ if [[ "$gyro_arch" == "i686" ]]; then
+ gyro_arch="i386"
+ fi
+ install -Dm755 "${srcdir}/gyro-${pkgver}-linux-${gyro_arch}/bin/gyro" "$pkgdir/usr/bin/gyro"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+