summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-06-07 21:34:09 +0200
committerJan Cholasta2020-06-07 21:35:29 +0200
commit314d96850eacba633d112db68e4816c4a01aeddc (patch)
tree7fb6d7ff7f6c5803f84e99da5d156f330c6cbda4
parent60441473de47f088de04654790f3c9a71763effa (diff)
parentf013f122364fe8453762a2421625b8f3b670f8be (diff)
downloadaur-314d96850eacba633d112db68e4816c4a01aeddc.tar.gz
gzdoom-4.4.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--0001-Fix-file-paths.patch93
-rw-r--r--0001-Fix-soundfont-search-path.patch33
-rw-r--r--PKGBUILD86
4 files changed, 131 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33ce1ff3816d..f24054878681 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
pkgbase = gzdoom
pkgdesc = Advanced Doom source port with OpenGL support
- pkgver = 4.3.3
- pkgrel = 2
+ pkgver = 4.4.0
+ pkgrel = 1
url = http://www.zdoom.org/
arch = i686
arch = x86_64
license = BSD
- license = custom:dumb
license = GPL3
license = LGPL3
makedepends = cmake
makedepends = desktop-file-utils
makedepends = git
- depends = alsa-lib
- depends = fluidsynth>=2
depends = gtk3
depends = hicolor-icon-theme
depends = libgl
depends = libjpeg
- depends = libsndfile
- depends = mpg123
depends = openal
depends = sdl2
+ depends = zmusic
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
@@ -34,18 +30,17 @@ pkgbase = gzdoom
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
optdepends = kdialog: crash dialog (KDE)
- optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
replaces = gzdoom1
- source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g4.3.3
+ source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g4.4.0
source = gzdoom.desktop
- source = 0001-Fix-soundfont-search-path.patch
+ source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61
+ sha256sums = ee6629e35d0422dff628cf715244a8a444b9cb9fac4e11f2b852ee7f23f4d587
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
new file mode 100644
index 000000000000..0d4124f1d201
--- /dev/null
+++ b/0001-Fix-file-paths.patch
@@ -0,0 +1,93 @@
+From 401bce4a69d773cbacc28df57004155204dbe707 Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Tue, 25 Feb 2020 12:53:07 +0100
+Subject: [PATCH] Fix file paths
+
+---
+ src/common/audio/music/i_soundfont.cpp | 4 +---
+ src/common/platform/posix/sdl/i_main.cpp | 14 +-------------
+ src/gameconfigfile.cpp | 14 ++------------
+ 3 files changed, 4 insertions(+), 28 deletions(-)
+
+diff --git a/src/common/audio/music/i_soundfont.cpp b/src/common/audio/music/i_soundfont.cpp
+index a8b4e9fdf..911b8e308 100644
+--- a/src/common/audio/music/i_soundfont.cpp
++++ b/src/common/audio/music/i_soundfont.cpp
+@@ -232,9 +232,7 @@ FPatchSetReader::FPatchSetReader(const char *filename)
+ #ifndef _WIN32
+ mCaseSensitivePaths = true;
+ const char *paths[] = {
+- "/usr/local/lib/timidity",
+- "/etc/timidity",
+- "/etc"
++ "/etc/timidity++"
+ };
+ #else
+ const char *paths[] = {
+diff --git a/src/common/platform/posix/sdl/i_main.cpp b/src/common/platform/posix/sdl/i_main.cpp
+index 7fc179a51..f39a38440 100644
+--- a/src/common/platform/posix/sdl/i_main.cpp
++++ b/src/common/platform/posix/sdl/i_main.cpp
+@@ -129,19 +129,7 @@ int main (int argc, char **argv)
+ Args = new FArgs(argc, argv);
+
+ // Should we even be doing anything with progdir on Unix systems?
+- char program[PATH_MAX];
+- if (realpath (argv[0], program) == NULL)
+- strcpy (program, argv[0]);
+- char *slash = strrchr (program, '/');
+- if (slash != NULL)
+- {
+- *(slash + 1) = '\0';
+- progdir = program;
+- }
+- else
+- {
+- progdir = "./";
+- }
++ progdir = "/usr/lib/gzdoom/";
+
+ I_StartupJoysticks();
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index 7f7e55a21..8dfd6a9b3 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -109,8 +109,6 @@ FGameConfigFile::FGameConfigFile ()
+ // Arch Linux likes them in /usr/share/doom
+ // Debian likes them in /usr/share/games/doom
+ // I assume other distributions don't do anything radically different
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -130,8 +128,6 @@ FGameConfigFile::FGameConfigFile ()
+ #else
+ SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
+ SetValueForKey ("Path", SHARE_DIR, true);
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -157,14 +153,8 @@ FGameConfigFile::FGameConfigFile ()
+ #else
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
++ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/soundfonts", true);
++ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/fm_banks", true);
+ #endif
+ }
+
+--
+2.27.0
+
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
deleted file mode 100644
index 0c1ac9da73fd..000000000000
--- a/0001-Fix-soundfont-search-path.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From c70f3a7973eef99c6709f11be75d7fe1bdc29efd Mon Sep 17 00:00:00 2001
-From: Jan Cholasta <jan@cholasta.net>
-Date: Mon, 5 Mar 2018 16:17:24 +0100
-Subject: [PATCH] Fix soundfont search path
-
----
- src/gameconfigfile.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index 2979420f9..c8f22895c 100644
---- a/src/gameconfigfile.cpp
-+++ b/src/gameconfigfile.cpp
-@@ -149,6 +149,8 @@ FGameConfigFile::FGameConfigFile ()
- #else
- SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
- SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
-+ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
-+ SetValueForKey("Path", SHARE_DIR "/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
-@@ -157,6 +159,7 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
-+ SetValueForKey("Path", "/usr/share/soundfonts", true);
- #endif
- }
-
---
-2.19.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 8d332b9494cc..5c66a82d9c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,20 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: Christoph Zeiler <rabyte*gmail>
-_name=gzdoom
-pkgname=${_name}
-pkgver=4.3.3
-pkgrel=2
+pkgname=gzdoom
+pkgver=4.4.0
+pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
-license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
-depends=('alsa-lib'
- 'fluidsynth>=2'
- 'gtk3'
+license=('BSD' 'GPL3' 'LGPL3')
+depends=('gtk3'
'hicolor-icon-theme'
'libgl'
'libjpeg'
- 'libsndfile'
- 'mpg123'
'openal'
- 'sdl2')
+ 'sdl2'
+ 'zmusic')
makedepends=('cmake' 'desktop-file-utils' 'git')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
@@ -32,63 +28,45 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
'kdialog: crash dialog (KDE)'
- 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
optdepends_x86_64=('vulkan-driver: Vulkan renderer'
'vulkan-icd-loader: Vulkan renderer')
-replaces=("${_name}1")
-source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
- "${_name}.desktop"
- '0001-Fix-soundfont-search-path.patch')
+replaces=("gzdoom1")
+source=("gzdoom::git://github.com/coelckers/gzdoom.git#tag=g${pkgver}"
+ 'gzdoom.desktop'
+ '0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61')
+ 'ee6629e35d0422dff628cf715244a8a444b9cb9fac4e11f2b852ee7f23f4d587')
prepare() {
- cd $_name
-
- patch -p1 -i"$srcdir"/0001-Fix-soundfont-search-path.patch
+ cd gzdoom
+ patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
}
build() {
- cd $_name
-
- local _cflags="-ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/$_name\\\""
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS="${CFLAGS} ${_cflags}" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} ${_cflags}" \
- -DCMAKE_EXE_LINKER_FLAGS="${LDFLAGS} -Wl,-z,noexecstack" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DDYN_FLUIDSYNTH=OFF \
- -DDYN_GTK=OFF \
- -DDYN_MPG123=OFF \
- -DDYN_OPENAL=OFF \
- -DDYN_SNDFILE=OFF \
- -DINSTALL_PATH=bin \
- -DINSTALL_PK3_PATH=share/$_name \
- .
- make
+ cd gzdoom
+ mkdir -p build
+ cmake -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/gzdoom\\\"" \
+ -D DYN_GTK=OFF \
+ -D DYN_OPENAL=OFF
+ make -C build
}
package() {
- cd $_name
-
- make install DESTDIR="$pkgdir"
- install -D -m644 soundfonts/gzdoom.sf2 \
- "$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
- install -D -m644 fm_banks/GENMIDI.GS.wopl \
- "$pkgdir"/usr/share/$_name/fm_banks/GENMIDI.GS.wopl
- install -D -m644 fm_banks/gs-by-papiezak-and-sneakernets.wopn \
- "$pkgdir"/usr/share/$_name/fm_banks/gs-by-papiezak-and-sneakernets.wopn
-
- desktop-file-install --dir="$pkgdir"/usr/share/applications \
- "$srcdir"/${_name}.desktop
- install -D -m644 src/posix/zdoom.xpm \
- "$pkgdir"/usr/share/icons/hicolor/256x256/apps/${_name}.xpm
-
- install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/doc/$_name/licenses "$pkgdir"/usr/share/licenses/$pkgname
+ cd gzdoom
+ install build/gzdoom -t "$pkgdir"/usr/bin -D
+ install build/gzdoom.pk3 -t "$pkgdir"/usr/lib/gzdoom -D -m 644
+ desktop-file-install "$srcdir"/gzdoom.desktop --dir="$pkgdir"/usr/share/applications
+ install docs/{console,rh-log,skins}.* -t "$pkgdir"/usr/share/doc/gzdoom -D -m 644
+ install build/{brightmaps,lights,game_support}.pk3 -t "$pkgdir"/usr/share/gzdoom -D -m 644
+ install build/soundfonts/gzdoom.sf2 -t "$pkgdir"/usr/share/gzdoom/soundfonts -D -m 644
+ install build/fm_banks/* -t "$pkgdir"/usr/share/gzdoom/fm_banks -D -m 644
+ install src/posix/zdoom.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/gzdoom.xpm -D -m 644
+ install docs/licenses/{bsd,fxaa,gdtoa,README}.* -t "$pkgdir"/usr/share/licenses/$pkgname -D -m 644
}