summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2016-12-27 18:38:46 +0100
committerJan Cholasta2016-12-27 19:02:56 +0100
commitbb446477d257030863cf2bec2d95dc7995ecc698 (patch)
treee805c93c01ab7d879f295b61056fa253beced69a
parent80cae1f1beb51d4fb068badd1d1e49b4fcab7979 (diff)
downloadaur-bb446477d257030863cf2bec2d95dc7995ecc698.tar.gz
gzdoom-2.2.0-2
* Build with the last fmodex version by default
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9c6a1d0c75..b0bee75d9180 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gzdoom
pkgdesc = Advanced Doom source port with OpenGL support
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.zdoom.org/
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = gzdoom
makedepends = imagemagick
makedepends = xdg-utils
depends = fluidsynth
- depends = fmodex4.26.36
+ depends = fmodex=4.44.62
depends = gtk2
depends = libgl
depends = libgme
diff --git a/PKGBUILD b/PKGBUILD
index bd8e949b8543..fa46599753e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: Christoph Zeiler <rabyte*gmail>
-# Build with the recommended fmodex version:
-_fmodex=fmodex4.26.36
-# Build with the currently installed fmodex version:
-#_fmodex=$(LC_ALL=C pacman -Q fmodex | sed -r 's/ /=/;s/-.*$//')
+# Build with fmodex:
+_fmodex=fmodex
# Build without fmodex:
#_fmodex=
@@ -16,15 +14,13 @@ _openal=openal
_name=gzdoom
pkgname=${_name}
pkgver=2.2.0
-pkgrel=1
-_label='GZDoom'
-_desc='Advanced Doom source port with OpenGL support'
-pkgdesc="${_desc}"
+pkgrel=2
+pkgdesc='Advanced Doom source port with OpenGL support'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
depends=('fluidsynth'
- ${_fmodex}
+ ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgl'
'libgme'
@@ -58,15 +54,15 @@ _srcsubdir="${_name}"
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d')
-prepare() {
+build() {
cd "${_srcsubdir}"
local _nofmod _noopenal _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
- _fmodincdir=$(LC_ALL=C pacman -Ql ${_fmodex%=*} | grep -Eo '/usr/include/fmodex[^/]*/$')
- _fmodlib=$(LC_ALL=C pacman -Ql ${_fmodex%=*} | grep -Eo '/usr/lib/libfmodex-[^/]*\.so$')
+ _fmodincdir=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/include/fmodex[^/]*/$')
+ _fmodlib=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/lib/libfmodex-[^/]*\.so$')
else
_nofmod=ON
fi
@@ -87,18 +83,13 @@ prepare() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"/usr/share/${_name}\\\"" \
-DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,noexecstack" \
.
-}
-
-build() {
- cd "${_srcsubdir}"
+ make
cat >"${_name}.sh" <<EOF
#!/bin/sh
exec /usr/lib/${_name}/${_name} "\$@"
EOF
- make
-
sed -n '/\*\*-/,/\*\*-/p' 'src/version.h' >'bsd.txt'
cp "${srcdir}/launcher.desktop" "${_name}.desktop"