summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-06-06 08:13:06 +0200
committerJan Cholasta2020-06-06 08:13:06 +0200
commitf013f122364fe8453762a2421625b8f3b670f8be (patch)
tree968cb631f5ccafe52416fc665a1d4edd38e9dcd8
parent8c0161515bd6ca5f8d64672654f1fc03e0022df7 (diff)
downloadaur-f013f122364fe8453762a2421625b8f3b670f8be.tar.gz
gzdoom-git-4.4pre+531+g9bf0f9bbf-1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch68
-rw-r--r--PKGBUILD4
3 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b57d95b1821e..3c6b69aa851b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Advanced Doom source port with OpenGL support (git version)
- pkgver = 4.4pre+300+g8c1db978b
+ pkgver = 4.4pre+531+g9bf0f9bbf
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -42,7 +42,7 @@ pkgbase = gzdoom-git
source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = fc96a19bccf9b53f23865d29632e6fab14386bde2e95ff9523d91b1c5fde6309
+ sha256sums = ee6629e35d0422dff628cf715244a8a444b9cb9fac4e11f2b852ee7f23f4d587
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index f87860eed411..0d4124f1d201 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,12 +1,12 @@
-From d52c1fbe2904fb301cc902e3f5523f9ea8f712ce Mon Sep 17 00:00:00 2001
+From 401bce4a69d773cbacc28df57004155204dbe707 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Tue, 25 Feb 2020 12:53:07 +0100
Subject: [PATCH] Fix file paths
---
- src/common/audio/music/i_soundfont.cpp | 4 +---
- src/gameconfigfile.cpp | 14 ++------------
- src/posix/sdl/i_main.cpp | 14 +-------------
+ src/common/audio/music/i_soundfont.cpp | 4 +---
+ src/common/platform/posix/sdl/i_main.cpp | 14 +-------------
+ src/gameconfigfile.cpp | 14 ++------------
3 files changed, 4 insertions(+), 28 deletions(-)
diff --git a/src/common/audio/music/i_soundfont.cpp b/src/common/audio/music/i_soundfont.cpp
@@ -24,11 +24,36 @@ index a8b4e9fdf..911b8e308 100644
};
#else
const char *paths[] = {
+diff --git a/src/common/platform/posix/sdl/i_main.cpp b/src/common/platform/posix/sdl/i_main.cpp
+index 7fc179a51..f39a38440 100644
+--- a/src/common/platform/posix/sdl/i_main.cpp
++++ b/src/common/platform/posix/sdl/i_main.cpp
+@@ -129,19 +129,7 @@ int main (int argc, char **argv)
+ Args = new FArgs(argc, argv);
+
+ // Should we even be doing anything with progdir on Unix systems?
+- char program[PATH_MAX];
+- if (realpath (argv[0], program) == NULL)
+- strcpy (program, argv[0]);
+- char *slash = strrchr (program, '/');
+- if (slash != NULL)
+- {
+- *(slash + 1) = '\0';
+- progdir = program;
+- }
+- else
+- {
+- progdir = "./";
+- }
++ progdir = "/usr/lib/gzdoom/";
+
+ I_StartupJoysticks();
+
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index a04264dbe..55e66bc4c 100644
+index 7f7e55a21..8dfd6a9b3 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -108,8 +108,6 @@ FGameConfigFile::FGameConfigFile ()
+@@ -109,8 +109,6 @@ FGameConfigFile::FGameConfigFile ()
// Arch Linux likes them in /usr/share/doom
// Debian likes them in /usr/share/games/doom
// I assume other distributions don't do anything radically different
@@ -37,7 +62,7 @@ index a04264dbe..55e66bc4c 100644
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -129,8 +127,6 @@ FGameConfigFile::FGameConfigFile ()
+@@ -130,8 +128,6 @@ FGameConfigFile::FGameConfigFile ()
#else
SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
SetValueForKey ("Path", SHARE_DIR, true);
@@ -46,7 +71,7 @@ index a04264dbe..55e66bc4c 100644
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -156,14 +152,8 @@ FGameConfigFile::FGameConfigFile ()
+@@ -157,14 +153,8 @@ FGameConfigFile::FGameConfigFile ()
#else
SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
@@ -63,31 +88,6 @@ index a04264dbe..55e66bc4c 100644
#endif
}
-diff --git a/src/posix/sdl/i_main.cpp b/src/posix/sdl/i_main.cpp
-index ed0e26450..baca003d7 100644
---- a/src/posix/sdl/i_main.cpp
-+++ b/src/posix/sdl/i_main.cpp
-@@ -187,19 +187,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
-- char program[PATH_MAX];
-- if (realpath (argv[0], program) == NULL)
-- strcpy (program, argv[0]);
-- char *slash = strrchr (program, '/');
-- if (slash != NULL)
-- {
-- *(slash + 1) = '\0';
-- progdir = program;
-- }
-- else
-- {
-- progdir = "./";
-- }
-+ progdir = "/usr/lib/gzdoom/";
-
- I_StartupJoysticks();
-
--
-2.26.0
+2.27.0
diff --git a/PKGBUILD b/PKGBUILD
index 9cb4414882b0..04baad02369d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=gzdoom-git
-pkgver=4.4pre+300+g8c1db978b
+pkgver=4.4pre+531+g9bf0f9bbf
pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support (git version)'
arch=('i686' 'x86_64')
@@ -41,7 +41,7 @@ source=('gzdoom::git://github.com/coelckers/gzdoom.git'
'0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- 'fc96a19bccf9b53f23865d29632e6fab14386bde2e95ff9523d91b1c5fde6309')
+ 'ee6629e35d0422dff628cf715244a8a444b9cb9fac4e11f2b852ee7f23f4d587')
pkgver() {
cd gzdoom