summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2021-08-03 08:22:11 +0200
committerJan Cholasta2021-08-03 08:22:11 +0200
commitfe194c15d3927669ebc4160b0f235ad8566105ab (patch)
treed4dfec424e778a5c940db152034c473838df6585
parentb3cc1091d2f0970e69dc093d01b9fbffa4abce6f (diff)
downloadaur-fe194c15d3927669ebc4160b0f235ad8566105ab.tar.gz
gzdoom-git-4.7.0pre+91+gf89e6950c-1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch36
-rw-r--r--PKGBUILD4
3 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ef200deb4e3..f0ff166d0f0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Feature centric port for all Doom engine games (git version)
- pkgver = 4.7.0pre+33+gadad028b3
+ pkgver = 4.7.0pre+91+gf89e6950c
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -43,7 +43,7 @@ pkgbase = gzdoom-git
source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 9b6c37c6fc90080ceb4162673f23187210b083af7cd61294ece2711790eac186
+ sha256sums = 7db3c08eb3756a19a9b6eda76f169e82e8c47b9a28108f17aac24774e2e53ff1
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index bd229c9d53ed..d8356f6f080d 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,18 +1,18 @@
-From ae97c9c15f3ee0d63573a319afda1e15fbe40cce Mon Sep 17 00:00:00 2001
+From 4daa1663a0fe0fb0cbf416ee064e0382bd5d5bda Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Tue, 25 Feb 2020 12:53:07 +0100
Subject: [PATCH] Fix file paths
---
src/common/platform/posix/sdl/i_main.cpp | 14 +-------------
- src/gameconfigfile.cpp | 14 ++------------
- 2 files changed, 3 insertions(+), 25 deletions(-)
+ src/gameconfigfile.cpp | 10 ++--------
+ 2 files changed, 3 insertions(+), 21 deletions(-)
diff --git a/src/common/platform/posix/sdl/i_main.cpp b/src/common/platform/posix/sdl/i_main.cpp
-index 7fc179a51..f39a38440 100644
+index b52561fdf..7260dab91 100644
--- a/src/common/platform/posix/sdl/i_main.cpp
+++ b/src/common/platform/posix/sdl/i_main.cpp
-@@ -129,19 +129,7 @@ int main (int argc, char **argv)
+@@ -175,19 +175,7 @@ int main (int argc, char **argv)
Args = new FArgs(argc, argv);
// Should we even be doing anything with progdir on Unix systems?
@@ -34,10 +34,10 @@ index 7fc179a51..f39a38440 100644
I_StartupJoysticks();
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index 7f7e55a21..8dfd6a9b3 100644
+index 830cef232..2b49b26d9 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -109,8 +109,6 @@ FGameConfigFile::FGameConfigFile ()
+@@ -119,8 +119,6 @@ FGameConfigFile::FGameConfigFile ()
// Arch Linux likes them in /usr/share/doom
// Debian likes them in /usr/share/games/doom
// I assume other distributions don't do anything radically different
@@ -46,32 +46,28 @@ index 7f7e55a21..8dfd6a9b3 100644
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -130,8 +128,6 @@ FGameConfigFile::FGameConfigFile ()
- #else
+@@ -141,8 +139,6 @@ FGameConfigFile::FGameConfigFile ()
SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
+ SetValueForKey ("Path", "$HOME/.local/share/games/doom", true);
SetValueForKey ("Path", SHARE_DIR, true);
- SetValueForKey ("Path", "/usr/local/share/doom", true);
- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -157,14 +153,8 @@ FGameConfigFile::FGameConfigFile ()
- #else
- SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
+@@ -170,10 +166,8 @@ FGameConfigFile::FGameConfigFile ()
SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/fm_banks", true);
-- SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
-- SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/fm_banks", true);
- #endif
- }
-
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
--
-2.28.0
+2.32.0
diff --git a/PKGBUILD b/PKGBUILD
index 70955fb1574f..2a9358b94e70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=gzdoom-git
-pkgver=4.7.0pre+33+gadad028b3
+pkgver=4.7.0pre+91+gf89e6950c
pkgrel=1
pkgdesc='Feature centric port for all Doom engine games (git version)'
arch=('i686' 'x86_64')
@@ -41,7 +41,7 @@ source=('gzdoom::git://github.com/coelckers/gzdoom.git'
'0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '9b6c37c6fc90080ceb4162673f23187210b083af7cd61294ece2711790eac186')
+ '7db3c08eb3756a19a9b6eda76f169e82e8c47b9a28108f17aac24774e2e53ff1')
pkgver() {
cd gzdoom