summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2018-03-25 17:30:01 +0200
committerJan Cholasta2018-03-25 17:33:11 +0200
commit4f6f557f5d1cc908660c1f490e2bc15cf12e12bd (patch)
tree639d692dced4ffffb2ae810901dfe9cc83a04f96
parented57151cf10757e240c09feb7946176bc697916e (diff)
downloadaur-4f6f557f5d1cc908660c1f490e2bc15cf12e12bd.tar.gz
gzdoom-git-3.3pre+725+gc0893027d-1
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Fix-soundfont-search-path.patch15
-rw-r--r--PKGBUILD5
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6684c7c4053e..16de0e340836 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Advanced Doom source port with OpenGL support (git version)
- pkgver = 3.3pre+560+gadae6c19b
+ pkgver = 3.3pre+725+gc0893027d
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -39,7 +39,6 @@ pkgbase = gzdoom-git
optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
- optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
provides = gzdoom
@@ -50,7 +49,7 @@ pkgbase = gzdoom-git
source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 066f1e3433ec3762ab9f91b72f6ec89bdb140a990d338d63fda68b33e4d19e22
+ sha256sums = 26cd2fa2285bcf4c9147a7f1763c217c3e7056bd4a729824f9af0104f6f410c9
pkgname = gzdoom-git
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
index 4477a58ca58f..55b948c6870c 100644
--- a/0001-Fix-soundfont-search-path.patch
+++ b/0001-Fix-soundfont-search-path.patch
@@ -1,17 +1,17 @@
-From 8ff9b58295be9920534069344380e9f4d3c8b732 Mon Sep 17 00:00:00 2001
+From 6a33dc9c7d85f5974a0d7bad6f376099c52507be Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Mon, 5 Mar 2018 16:17:24 +0100
Subject: [PATCH] Fix soundfont search path
---
- src/gameconfigfile.cpp | 1 +
- 1 file changed, 1 insertion(+)
+ src/gameconfigfile.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index c2655c359..f429fdbeb 100644
+index c2655c359..caa221cfe 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -181,6 +181,7 @@ FGameConfigFile::FGameConfigFile ()
+@@ -181,10 +181,12 @@ FGameConfigFile::FGameConfigFile ()
SetValueForKey("Path", "$PROGDIR/soundfonts", true);
#else
SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
@@ -19,6 +19,11 @@ index c2655c359..f429fdbeb 100644
SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
++ SetValueForKey("Path", "/usr/share/soundfonts", true);
+ #endif
+ }
+
--
2.16.2
diff --git a/PKGBUILD b/PKGBUILD
index 13061f73de3b..c38b02c689d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=gzdoom
pkgname=${_name}-git
-pkgver=3.3pre+560+gadae6c19b
+pkgver=3.3pre+725+gc0893027d
pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support (git version)'
arch=('i686' 'x86_64')
@@ -38,7 +38,6 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
- 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
provides=("${_name}")
@@ -49,7 +48,7 @@ source=("${_name}::git://github.com/coelckers/${_name}.git"
'0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '066f1e3433ec3762ab9f91b72f6ec89bdb140a990d338d63fda68b33e4d19e22')
+ '26cd2fa2285bcf4c9147a7f1763c217c3e7056bd4a729824f9af0104f6f410c9')
pkgver() {
cd $_name