summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-09-17 11:17:53 +0200
committerJan Cholasta2017-09-17 11:17:53 +0200
commitc3a664a21b315be8849ce77338584a944b5bb00e (patch)
tree40ba4a00bb7e68e0bc0734ebad1cb9f264ebd348
parentda9ec6b5b11891667f5c4b385e8d0939a247d07a (diff)
downloadaur-c3a664a21b315be8849ce77338584a944b5bb00e.tar.gz
gzdoom-git-3.2pre+562+g9f742f8aa-1
* include gzdoom.sf2 * add soundfont-fluid optdepend
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Fix-path-to-FluidR3-soundfont.patch25
-rw-r--r--PKGBUILD16
-rwxr-xr-xgzdoom.sh2
4 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d0f132603b3..293ef479eb74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Advanced Doom source port with OpenGL support (git version)
- pkgver = 3.0pre+144+gc6a516089
+ pkgver = 3.2pre+562+g9f742f8aa
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -36,6 +36,7 @@ pkgbase = gzdoom-git
optdepends = libsndfile: WAV/FLAC/OGG audio support
optdepends = mpg123: MP3 audio support
optdepends = openal: in-game sound
+ optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
optdepends = timidity++: Timidity MIDI device
@@ -45,8 +46,10 @@ pkgbase = gzdoom-git
conflicts = gzdoom
source = gzdoom::git://github.com/coelckers/gzdoom.git
source = gzdoom.desktop
+ source = 0001-Fix-path-to-FluidR3-soundfont.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
+ sha256sums = 30c431cbf51602581bf2bdc66552c1228c50bcf4a4bb5d63eb80d6bc3c79abcf
pkgname = gzdoom-git
diff --git a/0001-Fix-path-to-FluidR3-soundfont.patch b/0001-Fix-path-to-FluidR3-soundfont.patch
new file mode 100644
index 000000000000..7c2e35768b6c
--- /dev/null
+++ b/0001-Fix-path-to-FluidR3-soundfont.patch
@@ -0,0 +1,25 @@
+From bb6019e8022a6983a34927ace17516b680ecc7e3 Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Sun, 17 Sep 2017 10:45:32 +0200
+Subject: [PATCH] Fix path to FluidR3 soundfont
+
+---
+ src/sound/mididevices/music_fluidsynth_mididevice.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sound/mididevices/music_fluidsynth_mididevice.cpp b/src/sound/mididevices/music_fluidsynth_mididevice.cpp
+index 07102c43d..c32a17d8b 100644
+--- a/src/sound/mididevices/music_fluidsynth_mididevice.cpp
++++ b/src/sound/mididevices/music_fluidsynth_mididevice.cpp
+@@ -327,7 +327,7 @@ FluidSynthMIDIDevice::FluidSynthMIDIDevice(const char *args)
+ }
+ #ifdef __unix__
+ // This is the standard location on Ubuntu.
+- if (LoadPatchSets("/usr/share/sounds/sf2/FluidR3_GS.sf2:/usr/share/sounds/sf2/FluidR3_GM.sf2"))
++ if (LoadPatchSets("/usr/share/soundfonts/FluidR3_GS.sf2:/usr/share/soundfonts/FluidR3_GM.sf2"))
+ {
+ return;
+ }
+--
+2.14.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 2a8ff5a830ba..10108100b1d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=gzdoom
pkgname=${_name}-git
-pkgver=3.0pre+144+gc6a516089
+pkgver=3.2pre+562+g9f742f8aa
pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support (git version)'
arch=('i686' 'x86_64')
@@ -35,6 +35,7 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'libsndfile: WAV/FLAC/OGG audio support'
'mpg123: MP3 audio support'
'openal: in-game sound'
+ 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
'timidity++: Timidity MIDI device'
@@ -43,9 +44,11 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
provides=("${_name}")
conflicts=("${_name}")
source=("${_name}::git://github.com/coelckers/${_name}.git"
- "${_name}.desktop")
+ "${_name}.desktop"
+ '0001-Fix-path-to-FluidR3-soundfont.patch')
sha256sums=('SKIP'
- '59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d')
+ '59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
+ '30c431cbf51602581bf2bdc66552c1228c50bcf4a4bb5d63eb80d6bc3c79abcf')
pkgver() {
cd $_name
@@ -53,6 +56,12 @@ pkgver() {
git describe --tags --match '[Gg]*' | sed -r 's/^[Gg]//;s/-/+/g'
}
+prepare() {
+ cd $_name
+
+ patch -p1 -i"$srcdir"/0001-Fix-path-to-FluidR3-soundfont.patch
+}
+
build() {
cd $_name
@@ -71,6 +80,7 @@ package() {
cd $_name
make install DESTDIR="$pkgdir"
+ install -D -m644 ${_name}.sf2 "$pkgdir"/usr/share/$_name
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop
diff --git a/gzdoom.sh b/gzdoom.sh
deleted file mode 100755
index 4ce9012671e1..000000000000
--- a/gzdoom.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/lib/gzdoom/gzdoom "$@"