summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2013-11-01 12:04:50 +0100
committerJan Cholasta2018-08-12 13:35:23 +0200
commit482e5f08c82bbdda3772b34d844b06f52608438f (patch)
treeeb402ea57d43b2fa1b222bb68d31973d1b5ab03e
downloadaur-482e5f08c82bbdda3772b34d844b06f52608438f.tar.gz
gzdoom-legacy-3.5.0-1
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore4
-rw-r--r--0001-Fix-soundfont-search-path.patch29
-rw-r--r--PKGBUILD86
-rw-r--r--gzdoom.desktop10
5 files changed, 183 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8272fc2dde4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = gzdoom-legacy
+ pkgdesc = Advanced Doom source port with OpenGL support (legacy version)
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = http://www.zdoom.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = custom:dumb
+ license = GPL3
+ license = LGPL3
+ makedepends = cmake
+ makedepends = desktop-file-utils
+ makedepends = fluidsynth
+ makedepends = git
+ makedepends = gtk3
+ depends = hicolor-icon-theme
+ depends = libgl
+ depends = libgme
+ depends = libjpeg
+ depends = sdl2
+ optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
+ optdepends = chexquest3-wad: Chex Quest 3 game data
+ optdepends = doom1-wad: Doom shareware game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
+ optdepends = gtk3: IWAD selection dialog
+ optdepends = gxmessage: crash dialog (GNOME)
+ optdepends = hacx-wad: HacX game data
+ optdepends = harmony-wad: Harmony game data
+ optdepends = heretic1-wad: Heretic shareware game data
+ optdepends = hexen1-wad: Hexen demo game data
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = libsndfile: WAV/FLAC/OGG audio support
+ optdepends = mpg123: MP3 audio support
+ optdepends = openal: in-game sound
+ optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
+ optdepends = strife0-wad: Strife shareware game data
+ optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
+ optdepends = xorg-xmessage: crash dialog (other)
+ provides = gzdoom
+ conflicts = gzdoom
+ source = gzdoom::git://github.com/drfrag666/gzdoom.git#tag=g3.5.0_legacy
+ source = gzdoom.desktop
+ source = 0001-Fix-soundfont-search-path.patch
+ sha256sums = SKIP
+ sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
+ sha256sums = b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1
+
+pkgname = gzdoom-legacy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f9e91a4d264
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/gzdoom
+/pkg/
+/src/
+/*.pkg.tar.*
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
new file mode 100644
index 000000000000..4209ab9f26fe
--- /dev/null
+++ b/0001-Fix-soundfont-search-path.patch
@@ -0,0 +1,29 @@
+From 6147e4496a26f0571a2918bbc82b4b1483df8545 Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Mon, 5 Mar 2018 16:17:24 +0100
+Subject: [PATCH] Fix soundfont search path
+
+---
+ src/gameconfigfile.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index cb47c3597..452fd4160 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -143,10 +143,12 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+ #else
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
++ SetValueForKey("Path", "/usr/share/soundfonts", true);
+ #endif
+ }
+
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80e3c15b04a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Jan Cholasta <grubber at grubber cz>
+
+_name=gzdoom
+pkgname=${_name}-legacy
+pkgver=3.5.0
+pkgrel=1
+pkgdesc='Advanced Doom source port with OpenGL support (legacy version)'
+arch=('i686' 'x86_64')
+url='http://www.zdoom.org/'
+license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
+depends=('hicolor-icon-theme'
+ 'libgl'
+ 'libgme'
+ 'libjpeg'
+ 'sdl2')
+makedepends=('cmake'
+ 'desktop-file-utils'
+ 'fluidsynth'
+ 'git'
+ 'gtk3')
+optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
+ 'chexquest3-wad: Chex Quest 3 game data'
+ 'doom1-wad: Doom shareware game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
+ 'gtk3: IWAD selection dialog'
+ 'gxmessage: crash dialog (GNOME)'
+ 'hacx-wad: HacX game data'
+ 'harmony-wad: Harmony game data'
+ 'heretic1-wad: Heretic shareware game data'
+ 'hexen1-wad: Hexen demo game data'
+ 'kdialog: crash dialog (KDE)'
+ 'libsndfile: WAV/FLAC/OGG audio support'
+ 'mpg123: MP3 audio support'
+ 'openal: in-game sound'
+ 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
+ 'strife0-wad: Strife shareware game data'
+ 'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
+ 'xorg-xmessage: crash dialog (other)')
+provides=("${_name}")
+conflicts=("${_name}")
+source=("${_name}::git://github.com/drfrag666/${_name}.git#tag=g${pkgver}_legacy"
+ "${_name}.desktop"
+ '0001-Fix-soundfont-search-path.patch')
+sha256sums=('SKIP'
+ '59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
+ 'b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1')
+
+prepare() {
+ cd $_name
+
+ patch -p1 -i"$srcdir"/0001-Fix-soundfont-search-path.patch
+}
+
+build() {
+ cd $_name
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_FLAGS="$CFLAGS -DSHARE_DIR=\\\"/usr/share/$_name\\\"" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"/usr/share/$_name\\\"" \
+ -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,noexecstack" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_PATH=bin \
+ -DINSTALL_PK3_PATH=share/$_name \
+ .
+ make
+}
+
+package() {
+ cd $_name
+
+ make install DESTDIR="$pkgdir"
+ install -D -m644 soundfonts/gzdoom.sf2 \
+ "$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
+
+ desktop-file-install --dir="$pkgdir"/usr/share/applications \
+ "$srcdir"/${_name}.desktop
+ install -D -m644 src/posix/zdoom.xpm \
+ "$pkgdir"/usr/share/icons/hicolor/256x256/apps/${_name}.xpm
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/doc/$_name/licenses "$pkgdir"/usr/share/licenses/$pkgname
+}
diff --git a/gzdoom.desktop b/gzdoom.desktop
new file mode 100644
index 000000000000..4de1fa826af6
--- /dev/null
+++ b/gzdoom.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=GZDoom
+GenericName=Advanced Doom source port with OpenGL support
+Icon=gzdoom
+Exec=gzdoom %F
+Terminal=false
+MimeType=application/x-doom-wad;
+Categories=Game;ActionGame;