summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2018-12-30 09:17:26 +0100
committerJan Cholasta2018-12-30 09:18:42 +0100
commit0596956b0a51eec8ca96d9ffa3289b79380c1e36 (patch)
treeb127b7fc839ba70e9630c93b42202f4ccfda4707
parent0c0f59c19500cd00e371e30988e8a73d4f8bbe0a (diff)
parent6c0fc34a5e85d4c5e23866dcf425a1c3b871282d (diff)
downloadaur-0596956b0a51eec8ca96d9ffa3289b79380c1e36.tar.gz
gzdoom-legacy-git-g3.7.0_legacy-1
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Fix-soundfont-search-path.patch20
-rw-r--r--PKGBUILD16
3 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dc39bbaf4ba..826c9cd7c473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-legacy-git
pkgdesc = Advanced Doom source port with OpenGL support (git legacy version)
- pkgver = g3.5.0_legacy+9+g169c41e14
+ pkgver = g3.7.0_legacy
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = gzdoom-legacy-git
makedepends = fluidsynth
makedepends = git
makedepends = gtk3
+ depends = asmjit-git
depends = hicolor-icon-theme
depends = libgl
depends = libgme
@@ -48,7 +49,7 @@ pkgbase = gzdoom-legacy-git
source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1
+ sha256sums = 11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61
pkgname = gzdoom-legacy-git
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
index 4209ab9f26fe..0c1ac9da73fd 100644
--- a/0001-Fix-soundfont-search-path.patch
+++ b/0001-Fix-soundfont-search-path.patch
@@ -1,29 +1,33 @@
-From 6147e4496a26f0571a2918bbc82b4b1483df8545 Mon Sep 17 00:00:00 2001
+From c70f3a7973eef99c6709f11be75d7fe1bdc29efd Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Mon, 5 Mar 2018 16:17:24 +0100
Subject: [PATCH] Fix soundfont search path
---
- src/gameconfigfile.cpp | 2 ++
- 1 file changed, 2 insertions(+)
+ src/gameconfigfile.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index cb47c3597..452fd4160 100644
+index 2979420f9..c8f22895c 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -143,10 +143,12 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+@@ -149,6 +149,8 @@ FGameConfigFile::FGameConfigFile ()
#else
SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+@@ -157,6 +159,7 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/soundfonts", true);
#endif
}
--
-2.18.0
+2.19.0
diff --git a/PKGBUILD b/PKGBUILD
index 0cf69688d4e4..760109165e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
_name=gzdoom
pkgname=${_name}-legacy-git
-pkgver=g3.5.0_legacy+9+g169c41e14
+pkgver=g3.7.0_legacy
pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support (git legacy version)'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
-depends=('hicolor-icon-theme'
+depends=('asmjit-git'
+ 'hicolor-icon-theme'
'libgl'
'libgme'
'libjpeg'
@@ -47,7 +48,7 @@ source=("${_name}::git://github.com/drfrag666/${_name}.git#branch=legacy"
'0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- 'b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1')
+ '11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61')
pkgver() {
cd $_name
@@ -68,7 +69,12 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS -DSHARE_DIR=\\\"/usr/share/$_name\\\"" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"/usr/share/$_name\\\"" \
-DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,noexecstack" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_asmjit=TRUE \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DASMJIT_FOUND=TRUE \
+ -DASMJIT_INCLUDE_DIR=/usr/include \
+ -DASMJIT_LIBRARIES=asmjit \
+ -DASMJIT_LIBRARY=asmjit \
-DINSTALL_PATH=bin \
-DINSTALL_PK3_PATH=share/$_name \
.
@@ -81,6 +87,10 @@ package() {
make install DESTDIR="$pkgdir"
install -D -m644 soundfonts/gzdoom.sf2 \
"$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
+ install -D -m644 fm_banks/GENMIDI.GS.wopl \
+ "$pkgdir"/usr/share/$_name/fm_banks/GENMIDI.GS.wopl
+ install -D -m644 fm_banks/gs-by-papiezak-and-sneakernets.wopn \
+ "$pkgdir"/usr/share/$_name/fm_banks/gs-by-papiezak-and-sneakernets.wopn
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop