summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-01-01 16:23:14 +0100
committerJan Cholasta2017-01-04 06:19:45 +0100
commit8291162ec8f6d78efb4d861175d7f4284bb566cb (patch)
treebc196c98b03f446dda8331a7ba9eab05d6eda950
parent7f7eef863863e2cf73007cd5867d183f58c1fa42 (diff)
downloadaur-8291162ec8f6d78efb4d861175d7f4284bb566cb.tar.gz
gzdoom1-1.9.1-4
* Build without fmodex by default * Make openal dependency optional * Make fluidsynth dependency optional * Add missing timidity++ optional dependency * Split freedoom optdepend to freedm, freedoom1, freedoom2 * Rename kdebase-kdialog optdepend to kdialog * Remove IWAD symlinks, as they are no longer functional
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b50ae7136ec..8d7ce31f999f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gzdoom1
pkgdesc = Advanced Doom source port with OpenGL support (legacy version)
pkgver = 1.9.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.zdoom.org/
arch = i686
arch = x86_64
@@ -12,30 +12,34 @@ pkgbase = gzdoom1
license = LGPL
makedepends = cmake
makedepends = desktop-file-utils
+ makedepends = fluidsynth
makedepends = git
makedepends = imagemagick
+ makedepends = openal
makedepends = xdg-utils
- depends = fluidsynth
- depends = fmodex=4.44.62
depends = gtk2
depends = libgl
depends = libgme
depends = libsndfile
depends = mpg123
- depends = openal
depends = sdl2
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
- optdepends = freedoom: FreeDoom game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
optdepends = gxmessage: crash dialog (GNOME)
optdepends = hacx-wad: HacX game data
optdepends = harmony-wad: Harmony game data
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
- optdepends = kdebase-kdialog: crash dialog (KDE)
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = openal: OpenAL sound backend
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
provides = gzdoom
diff --git a/PKGBUILD b/PKGBUILD
index b1d7f402cbba..bac2ef91bfb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
-# Build with fmodex:
-_fmodex=fmodex
# Build without fmodex:
-#_fmodex=
-
-# Build with OpenAL:
-_openal=openal
-# Build without OpenAL:
-#_openal=
+_fmodex=
+# Build with fmodex:
+#_fmodex=fmodex
_name=gzdoom
pkgname=${_name}1
pkgver=1.9.1
-pkgrel=3
+pkgrel=4
pkgdesc='Advanced Doom source port with OpenGL support (legacy version)'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
-depends=('fluidsynth'
- ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
+depends=(${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgl'
'libgme'
- ${_openal:+'libsndfile'}
- ${_openal:+'mpg123'}
- ${_openal}
+ 'libsndfile'
+ 'mpg123'
'sdl2')
makedepends=('cmake'
'desktop-file-utils'
+ 'fluidsynth'
'git'
'imagemagick'
+ 'openal'
'xdg-utils')
makedepends_i686=('nasm')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
- 'freedoom: FreeDoom game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
'gxmessage: crash dialog (GNOME)'
'hacx-wad: HacX game data'
'harmony-wad: Harmony game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
- 'kdebase-kdialog: crash dialog (KDE)'
+ 'kdialog: crash dialog (KDE)'
+ 'openal: OpenAL sound backend'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
provides=("${_name}")
@@ -52,21 +52,20 @@ conflicts=("${_name}")
source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
'launcher.desktop'
'0001-Improve-Mac-GCC-errors-fix-to-work-only-for-GCC.patch')
-_srcsubdir="${_name}"
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
'0d2d7ec04d35359b20a927c5afed87e3aaaf3836953cfe534861a92316188174')
prepare() {
- cd "${_srcsubdir}"
+ cd $_name
patch -p 1 -i "$srcdir"/0001-Improve-Mac-GCC-errors-fix-to-work-only-for-GCC.patch
}
build() {
- cd "${_srcsubdir}"
+ cd $_name
- local _nofmod _noopenal _fmodincdir _fmodlib
+ local _nofmod _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
@@ -76,14 +75,7 @@ build() {
_nofmod=ON
fi
- if [[ -n "${_openal}" ]]; then
- _noopenal=OFF
- else
- _noopenal=ON
- fi
-
cmake -DNO_FMOD=${_nofmod} \
- -DNO_OPENAL=${_noopenal} \
-DGME_INCLUDE_DIR='/usr/include/gme' \
-DFMOD_INCLUDE_DIR="${_fmodincdir}" \
-DFMOD_LIBRARY="${_fmodlib}" \
@@ -110,7 +102,7 @@ EOF
}
package() {
- cd "${_srcsubdir}"
+ cd $_name
install -D "${_name}.sh" "${pkgdir}/usr/bin/${_name}"
@@ -120,10 +112,6 @@ package() {
if [[ -n "${_fmodex}" ]]; then
install 'liboutput_sdl.so' "${pkgdir}/usr/lib/${_name}/"
fi
- ln -s '/usr/share/doom/doom.wad' "${pkgdir}/usr/lib/${_name}/freedoomu.wad"
- ln -s '/usr/share/doom/doom2.wad' "${pkgdir}/usr/lib/${_name}/freedoom.wad"
- ln -s '/usr/share/doom/heretic.wad' "${pkgdir}/usr/lib/${_name}/blasphemer.wad"
- ln -s '/usr/share/doom/hexen.wad' "${pkgdir}/usr/lib/${_name}/hexendemo.wad"
mkdir -p "${pkgdir}/usr/share/${_name}"
install -m644 'brightmaps.pk3' "${pkgdir}/usr/share/${_name}/"