summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁrni Dagur2019-01-30 00:30:44 +0000
committerÁrni Dagur2019-01-30 00:30:44 +0000
commite5b112041d2281032fe71af7c77de56d68afd1c0 (patch)
treebd27576e07e3f37b9437862068bef8a5678add85
downloadaur-e5b112041d2281032fe71af7c77de56d68afd1c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..004a1bf9fefe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gzip-with-pigz-symlinks
+ pkgdesc = gzip with binary symlinked to pigz
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://www.gnu.org/software/gzip/
+ arch = x86_64
+ license = GPL3
+ depends = pigz
+ depends = bash
+ depends = less
+ provides = gzip
+ conflicts = gzip
+ source = https://ftp.gnu.org/pub/gnu/gzip/gzip-1.10.tar.xz
+ md5sums = 691b1221694c3394f1c537df4eee39d3
+
+pkgname = gzip-with-pigz-symlinks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dddf303381a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainter: Árni Dagur <arnidg@protonmail.ch>
+# Adapted from original PKGBULID written by: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
+
+pkgname=gzip-with-pigz-symlinks
+pkgver=1.10
+pkgrel=1
+pkgdesc='gzip with binary symlinked to pigz'
+arch=('x86_64')
+url='https://www.gnu.org/software/gzip/'
+license=('GPL3')
+depends=('pigz' 'bash' 'less')
+provides=('gzip')
+conflicts=('gzip')
+source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz")
+md5sums=('691b1221694c3394f1c537df4eee39d3')
+
+build() {
+ cd gzip-$pkgver
+ ./configure prefix=/usr
+ make
+}
+
+package() {
+ cd gzip-$pkgver
+
+ make prefix="$pkgdir"/usr install
+ ln -sf pigz "$pkgdir"/usr/bin/gzip
+}