summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Moore2024-02-18 12:07:48 -0500
committerMatt Moore2024-02-18 15:33:06 -0500
commit85df59958b4b36ab507502ef5deca47df20630f2 (patch)
treefff20ed75a679ded4541f202096118ec65e8049c
downloadaur-85df59958b4b36ab507502ef5deca47df20630f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7751b666e802
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = h2ogames
+ pkgdesc = Game management client for h2o games.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mattmoore/h2o
+ arch = x86_64
+ license = Apache-2.0
+ depends = xz
+ depends = glibc
+ depends = gcc-libs
+ source = https://github.com/mattmoore/h2o/releases/download/v0.1.0/h2o-0.1.0.tar.xz
+ sha512sums = f2524341bc1c0a50585be71bbb4ac91404cd69806ad87462a9990c008ccd0377a56240f4f6443db0e1f4f6ef5a00e400462458ab062a81b045819072567719c7
+
+pkgname = h2ogames
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73c8e9f4ee8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Matt Moore <matt@mattmoore.io>
+_pkgname=h2o
+pkgname=h2ogames
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="Game management client for h2o games."
+arch=("x86_64")
+url="https://github.com/mattmoore/h2o"
+license=('Apache-2.0')
+groups=()
+depends=(
+ 'xz'
+ 'glibc'
+ 'gcc-libs'
+)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/mattmoore/h2o/releases/download/v0.1.0/$_pkgname-$pkgver.tar.xz")
+sha512sums=("f2524341bc1c0a50585be71bbb4ac91404cd69806ad87462a9990c008ccd0377a56240f4f6443db0e1f4f6ef5a00e400462458ab062a81b045819072567719c7")
+validpgpkeys=()
+
+package() {
+ mkdir -p "${pkgdir}/usr/lib"
+ cp libh2o.rlib "${pkgdir}/usr/lib/"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp h2o "${pkgdir}/usr/bin/"
+}