summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2017-11-14 07:35:59 -0200
committerLucas Heitzmann Gabrielli2017-11-14 07:35:59 -0200
commita04dd54f3ba77654e7d371fab14a89803ba3ac29 (patch)
tree8558e63e600ebd9341c4b1b5155cf92435544e9b
downloadaur-a04dd54f3ba77654e7d371fab14a89803ba3ac29.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1569aaf3f7c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = h5utils-git
+ pkgdesc = A set of utilities for visualization and conversion of scientific data in the free, portable HDF5 format
+ pkgver = 1.13.r7.g830b7f9
+ pkgrel = 1
+ url = https://github.com/stevengj/h5utils
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = GPL
+ depends = hdf5
+ depends = libpng
+ optdepends = libmatheval: support symbolic expressions
+ provides = h5utils
+ conflicts = h5utils
+ options = !makeflags
+ source = git+https://github.com/stevengj/h5utils.git
+ sha256sums = SKIP
+
+pkgname = h5utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78af6cf3de97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+pkgname=h5utils-git
+pkgver=1.13.r7.g830b7f9
+pkgrel=1
+pkgdesc='A set of utilities for visualization and conversion of scientific data in the free, portable HDF5 format'
+arch=('i686' 'x86_64')
+url='https://github.com/stevengj/h5utils'
+license=('MIT' 'GPL')
+depends=('hdf5' 'libpng')
+optdepends=('libmatheval: support symbolic expressions')
+options=('!makeflags')
+provides=('h5utils')
+conflicts=('h5utils')
+source=('git+https://github.com/stevengj/h5utils.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/h5utils"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/h5utils"
+
+ #Fix for libpng upgrade problem adapted from https://gist.github.com/1626861
+ mv writepng.c tmpfile1
+ sed 's/png_ptr->jmpbuf/png_jmpbuf (png_ptr)/g' tmpfile1 > writepng.c
+ mv writepng.c tmpfile2
+ sed 's/free(info_ptr->palette)\;/\/\* free(info_ptr->palette); \*\//g' tmpfile2 > writepng.c
+
+ ./autogen.sh --prefix=/usr
+ make
+
+}
+
+package() {
+ cd "${srcdir}/h5utils"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}