summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2017-04-16 11:27:09 -0400
committerDavid Parrish2017-04-16 11:27:09 -0400
commitd6f50ed8b939de38f4fe508c5ede58eba7829eae (patch)
treeee844df3b62ecafb175502bd9036acb1babacfe8
downloadaur-d6f50ed8b939de38f4fe508c5ede58eba7829eae.tar.gz
Initial commit for habitat-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7c669337ebc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Apr 16 15:26:08 UTC 2017
+pkgbase = habitat-git
+ pkgdesc = Application automation framework that allows you to build applications that have automation built-in
+ pkgver = 0.20.0
+ pkgrel = 1
+ url = https://www.habitat.sh/
+ arch = x86_64
+ license = Apache
+ makedepends = cargo
+ depends = libarchive
+ depends = libsodium
+ source = habitat-git::git+https://github.com/habitat-sh/habitat.git
+ sha256sums = SKIP
+
+pkgname = habitat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9349a1ba224d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=habitat-git
+pkgver=0.20.0
+pkgrel=1
+pkgdesc="Application automation framework that allows you to build applications that have automation built-in"
+arch=('x86_64')
+url="https://www.habitat.sh/"
+license=('Apache')
+depends=('libarchive' 'libsodium')
+makedepends=('cargo')
+source=("${pkgname}::git+https://github.com/habitat-sh/habitat.git")
+sha256sums=('SKIP')
+
+build() {
+ # Use a temporary local Cargo repository.
+ export CARGO_HOME="${srcdir}/cargo-repository"
+
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+# Commented out because tests ask for sudo access
+#check() {
+# # Use a temporary local Cargo repository.
+# export CARGO_HOME="$srcdir/cargo-repository"
+#
+# cd "${srcdir}/${pkgname}"
+# make test
+#}
+
+package() {
+ install -D -m755 "${srcdir}/${pkgname}/target/debug/hab" "${pkgdir}/usr/bin/hab"
+}