summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2017-04-16 11:33:51 -0400
committerDavid Parrish2017-04-16 11:33:51 -0400
commitefef925e1f83d77e5c1b8f630c66668b31b86edb (patch)
tree56cd9402db89c769d9dba1321e0c2bd0ed769d4b
parentd6f50ed8b939de38f4fe508c5ede58eba7829eae (diff)
downloadaur-efef925e1f83d77e5c1b8f630c66668b31b86edb.tar.gz
Add pkgver for determing the current version from git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7c669337ebc..8323a8a01fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Apr 16 15:26:08 UTC 2017
+# Sun Apr 16 15:33:07 UTC 2017
pkgbase = habitat-git
pkgdesc = Application automation framework that allows you to build applications that have automation built-in
- pkgver = 0.20.0
+ pkgver = 0.20.0.r64.g232f7c63
pkgrel = 1
url = https://www.habitat.sh/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9349a1ba224d..7afbd432f93a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=habitat-git
-pkgver=0.20.0
+pkgver=0.20.0.r64.g232f7c63
pkgrel=1
pkgdesc="Application automation framework that allows you to build applications that have automation built-in"
arch=('x86_64')
@@ -12,6 +12,11 @@ makedepends=('cargo')
source=("${pkgname}::git+https://github.com/habitat-sh/habitat.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
# Use a temporary local Cargo repository.
export CARGO_HOME="${srcdir}/cargo-repository"