summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Alsina2024-08-27 13:26:24 -0300
committerRoberto Alsina2024-08-27 13:26:24 -0300
commit7ecc310f27051a031c6e0d695520b40916f5f601 (patch)
tree9b6930454029826b2830684aba7e7f6fac5378a7
downloadaur-7ecc310f27051a031c6e0d695520b40916f5f601.tar.gz
v0.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--install35
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b8f2e0cf89c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hace
+ pkgdesc = A task-launching app (think make)
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/ralsina/hace
+ install = install
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = crystal
+ makedepends = shards
+ source = hace-0.2.0.tar.gz::https://github.com/ralsina/hace/archive/refs/tags/v0.2.0.tar.gz
+ sha256sums = 64267a4023c55b872b8de4f5846c89f3667a5b9fe519c22f190b037fa63e5dc4
+
+pkgname = hace
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6f0f119771c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Roberto Alsina <roberto.alsina@gmail.com>
+pkgname=hace
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A task-launching app (think make)"
+arch=('x86_64' 'aarch64')
+url="https://github.com/ralsina/hace"
+license=('MIT')
+makedepends=('crystal' 'shards')
+options=()
+install=install
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ralsina/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("64267a4023c55b872b8de4f5846c89f3667a5b9fe519c22f190b037fa63e5dc4")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ shards install --without-development
+ shards build --release --without-development
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 bin/${pkgname} $pkgdir/usr/bin/${pkgname}
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..f7f593f6ed0f
--- /dev/null
+++ b/install
@@ -0,0 +1,35 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+#post_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}