summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-01-02 21:08:06 +0100
committerMichal Wojdyla2021-01-02 21:08:06 +0100
commitb341c262ad72f274462a155ce9d26458bf8ed12e (patch)
treea244be09beb98f06fe2c2de3bc90bd03cfa25967
parent635a32f5dbdc7483f17ca7372ca2f9ab20d219fd (diff)
downloadaur-hachoir-core.tar.gz
update to 3.1.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4751b100735..19e2614344f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = hachoir-core
- pkgdesc = A library written in Python which allows to see and edit a binary files field per field.
- pkgver = 1.3.3
- pkgrel = 4
- url = http://bitbucket.org/haypo/hachoir/wiki/Home
+ pkgdesc = A Python library to view and edit a binary stream field by field.
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://pypi.org/project/hachoir/
arch = any
license = GPL2
- depends = python2
- source = http://cheeseshop.python.org/packages/source/h/hachoir-core/hachoir-core-1.3.3.tar.gz
- md5sums = b80f0257536e2b2cb23f66670c4f6f31
+ depends = python
+ source = https://github.com/vstinner/hachoir/archive/3.1.1.tar.gz
+ md5sums = 717a008a9ecd5fef551e015f0478654a
pkgname = hachoir-core
diff --git a/PKGBUILD b/PKGBUILD
index 618632915240..1d345b68a384 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
+# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com >
# Contributor: arno <apithon.AT.free.DOT.fr>
# Contributor: Pierre Bourdon <delroth@gmail.com>
-# Maintainer: ianux <ianux AT free DOT fr>
+# Contributor: ianux <ianux AT free DOT fr>
pkgname=hachoir-core
-pkgver=1.3.3
-pkgrel=4
-pkgdesc="A library written in Python which allows to see and edit a binary files field per field."
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="A Python library to view and edit a binary stream field by field."
arch=('any')
-url="http://bitbucket.org/haypo/hachoir/wiki/Home"
+url="https://pypi.org/project/hachoir/"
license=('GPL2')
-depends=('python2')
-source=(http://cheeseshop.python.org/packages/source/h/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('b80f0257536e2b2cb23f66670c4f6f31')
+depends=('python')
+source=(https://github.com/vstinner/hachoir/archive/$pkgver.tar.gz)
+md5sums=('717a008a9ecd5fef551e015f0478654a')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- python2 setup.py build
+ cd ${srcdir}/hachoir-${pkgver}
+ python setup.py build
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- python2 setup.py install --optimize=1 --root=${pkgdir}
+ cd ${srcdir}/hachoir-${pkgver}
+ python setup.py install --optimize=1 --root=${pkgdir}
}