summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorianux2015-06-10 12:59:13 +0200
committerianux2015-06-10 12:59:13 +0200
commit635a32f5dbdc7483f17ca7372ca2f9ab20d219fd (patch)
tree40e5515d925c4c7cbae2ee318907a739875d4d0a
downloadaur-635a32f5dbdc7483f17ca7372ca2f9ab20d219fd.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4751b100735
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hachoir-core
+ pkgdesc = A library written in Python which allows to see and edit a binary files field per field.
+ pkgver = 1.3.3
+ pkgrel = 4
+ url = http://bitbucket.org/haypo/hachoir/wiki/Home
+ arch = any
+ license = GPL2
+ depends = python2
+ source = http://cheeseshop.python.org/packages/source/h/hachoir-core/hachoir-core-1.3.3.tar.gz
+ md5sums = b80f0257536e2b2cb23f66670c4f6f31
+
+pkgname = hachoir-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..618632915240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: arno <apithon.AT.free.DOT.fr>
+# Contributor: Pierre Bourdon <delroth@gmail.com>
+# Maintainer: ianux <ianux AT free DOT fr>
+
+pkgname=hachoir-core
+pkgver=1.3.3
+pkgrel=4
+pkgdesc="A library written in Python which allows to see and edit a binary files field per field."
+arch=('any')
+url="http://bitbucket.org/haypo/hachoir/wiki/Home"
+license=('GPL2')
+depends=('python2')
+source=(http://cheeseshop.python.org/packages/source/h/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('b80f0257536e2b2cb23f66670c4f6f31')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install --optimize=1 --root=${pkgdir}
+}
+