summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorianux2015-06-10 12:59:45 +0200
committerianux2015-06-10 12:59:45 +0200
commit0fa8033abd8b1862acffc9a95038131cc3adf7b3 (patch)
tree27923f75da0c2c0acd0b6df915bb607765834172
downloadaur-0fa8033abd8b1862acffc9a95038131cc3adf7b3.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdb5d1372209
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hachoir-regex
+ pkgdesc = Regex manipulation Python library used by hachoir-subfile for fast pattern matching.
+ pkgver = 1.0.5
+ pkgrel = 2
+ url = http://bitbucket.org/haypo/hachoir/wiki/hachoir-regex
+ arch = any
+ license = GPL2
+ depends = python2
+ source = http://cheeseshop.python.org/packages/source/h/hachoir-regex/hachoir-regex-1.0.5.tar.gz
+ md5sums = 6e1430cc5efcf82b6895364a6bf36d11
+
+pkgname = hachoir-regex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..176fb13a08d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: arno <apithon.AT.free.DOT.fr>
+# Contributor: Pierre Bourdon <delroth@gmail.com>
+# Maintainer: ianux <ianux AT free DOT fr>
+
+pkgname=hachoir-regex
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="Regex manipulation Python library used by hachoir-subfile for fast pattern matching."
+arch=('any')
+url="http://bitbucket.org/haypo/hachoir/wiki/hachoir-regex"
+license=('GPL2')
+depends=('python2')
+source=(http://cheeseshop.python.org/packages/source/h/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('6e1430cc5efcf82b6895364a6bf36d11')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install --optimize=1 --root=${pkgdir}
+}