summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordankcuddlybear2022-05-18 21:11:49 +0100
committerdankcuddlybear2022-05-18 21:11:49 +0100
commitcaf2b3b698962d544ed0dec1722e799329ba2f94 (patch)
tree1b3fa8bb0a493563cc6b2158bfd2133db15513ce
parent830b6ad96227bc82d331c37fa31b742f923f690d (diff)
downloadaur-caf2b3b698962d544ed0dec1722e799329ba2f94.tar.gz
Added ia32 support
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--hackbgrt-install11
-rw-r--r--hackbgrt.install3
4 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc497cb309f..59ca80ff661f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = hackbgrt-bin
- pkgdesc = Boot logo changer for 64 bit UEFI systems (precompiled)
+ pkgdesc = UEFI boot logo changer. Precompiled for 64 bit and 32 bit x86 UEFI.
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Metabolix/HackBGRT
install = hackbgrt.install
- arch = x86_64
+ arch = any
license = MIT
depends = efibootmgr
source = https://github.com/Metabolix/HackBGRT/releases/download/v1.5.1/HackBGRT-1.5.1.zip
source = hackbgrt-install
sha512sums = d4a362058cac10e3fa31665ee72370e0f4854fea07d9386112f0525bf4643f9d14fae25adf824fe2ab3723be2dd574c67491cc38174a989fa233e0d75e24ca84
- sha512sums = 39657aaf6a174a00ca05ef8a8c21f67c953e8f568c517033631ae8ee90d9e0ba5600a980b22a7d65e3956bbcacc821b48b9e0964e9708092d420622b7d2d5992
+ sha512sums = bd73df81e5632d7c63d054f6810fe8a2b0797987078b570c0d19840c85ab03cdcb28ef1a9bed2ccca19c7f7209b51149327c848e6d690a13afbba086b401beb0
pkgname = hackbgrt-bin
diff --git a/PKGBUILD b/PKGBUILD
index a92701d6f01b..d294090311c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Dankcuddlybear dankcuddlybear@protonmail.com
pkgname=hackbgrt-bin
pkgver=1.5.1
-pkgrel=1
-pkgdesc='Boot logo changer for 64 bit UEFI systems (precompiled)'
-arch=(x86_64)
+pkgrel=2
+pkgdesc='UEFI boot logo changer. Precompiled for 64 bit and 32 bit x86 UEFI.'
+arch=(any)
url='https://github.com/Metabolix/HackBGRT'
license=('MIT')
depends=('efibootmgr')
install=hackbgrt.install
source=('https://github.com/Metabolix/HackBGRT/releases/download/v1.5.1/HackBGRT-1.5.1.zip' 'hackbgrt-install')
-sha512sums=('d4a362058cac10e3fa31665ee72370e0f4854fea07d9386112f0525bf4643f9d14fae25adf824fe2ab3723be2dd574c67491cc38174a989fa233e0d75e24ca84' '39657aaf6a174a00ca05ef8a8c21f67c953e8f568c517033631ae8ee90d9e0ba5600a980b22a7d65e3956bbcacc821b48b9e0964e9708092d420622b7d2d5992')
+sha512sums=('d4a362058cac10e3fa31665ee72370e0f4854fea07d9386112f0525bf4643f9d14fae25adf824fe2ab3723be2dd574c67491cc38174a989fa233e0d75e24ca84' 'bd73df81e5632d7c63d054f6810fe8a2b0797987078b570c0d19840c85ab03cdcb28ef1a9bed2ccca19c7f7209b51149327c848e6d690a13afbba086b401beb0')
package() {
mkdir -p $pkgdir/usr/lib/hackbgrt $pkgdir/usr/bin
+ mv $srcdir/HackBGRT-1.5.1/bootia32.efi $pkgdir/usr/lib/hackbgrt/bootia32.efi
mv $srcdir/HackBGRT-1.5.1/bootx64.efi $pkgdir/usr/lib/hackbgrt/bootx64.efi
mv $srcdir/HackBGRT-1.5.1/config.txt $pkgdir/usr/lib/hackbgrt/config.txt
mv $srcdir/HackBGRT-1.5.1/setup.exe $pkgdir/usr/lib/hackbgrt/setup.exe
diff --git a/hackbgrt-install b/hackbgrt-install
index 6e247a064fb7..0f47278eb7e9 100644
--- a/hackbgrt-install
+++ b/hackbgrt-install
@@ -1,4 +1,9 @@
#!/bin/sh
+[ $(whoami) != "root" ] && echo "[ERROR] You must run this script with root priviliges." && exit 1
+if [ $1 == "32" ]; then BOOTNAME="bootia32"
+else if [ -z $
+BOOTNAME="bootx64"
+
# Try to detect EFI partition and mount point
ESPDEV=$(echo $(fdisk -l | grep -sm 1 "EFI System") | cut -d ' ' -f 1)
if [ ${ESPDEV:5:7} == "hd" ] || [ ${ESPDEV:5:7} == "sd" ] || [ ${ESPDEV:5:7} == "vd" ]; then
@@ -22,12 +27,12 @@ BOOTCURRENT=$(echo $BOOTCURRENT | grep -o -P "(?<=\)/File\().*(?=.efi\))").efi
mkdir -p $ESPDIR/EFI/boot $ESPDIR/EFI/HackBGRT
# Install HackBGRT to ESP
-cp -n /usr/lib/hackbgrt/bootx64.efi $ESPDIR/EFI/boot/bootx64.efi
-cp /usr/lib/hackbgrt/bootx64.efi $ESPDIR/EFI/HackBGRT/bootx64.efi
+cp -n /usr/lib/hackbgrt/$BOOTNAME.efi $ESPDIR/EFI/boot/$BOOTNAME.efi
+cp /usr/lib/hackbgrt/$BOOTNAME.efi $ESPDIR/EFI/HackBGRT/$BOOTNAME.efi
cp /usr/lib/hackbgrt/splash.bmp $ESPDIR/EFI/HackBGRT/splash.bmp
# Create HackBGRT bootloader entry
-efibootmgr -c -d $ESPDISK -p $ESPPART -L "HackBGRT" -l '\EFI\HackBGRT\bootx64.efi'
+efibootmgr -c -d $ESPDISK -p $ESPPART -L "HackBGRT" -l "\EFI\HackBGRT\\$BOOTNAME.efi"
# Create HackBGRT config file
echo "# vim: set fileencoding=utf-8" > $ESPDIR/EFI/HackBGRT/config.txt
diff --git a/hackbgrt.install b/hackbgrt.install
index 27229421686a..a26345073368 100644
--- a/hackbgrt.install
+++ b/hackbgrt.install
@@ -1,4 +1,5 @@
post_install() {
- echo "Run hackbgrt-install to install HackBGRT to the ESP."
+ echo "Run \"hackbgrt-install\" to install HackBGRT to the ESP."
+ echo "Run \"hackbgrt-install 32\" to install the 32 bit version instead of the 64 bit version."
echo "This will configure HackBGRT to boot the bootloader used to boot this system."
} \ No newline at end of file