summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanthora2023-07-05 11:27:11 +0000
committerlanthora2023-07-05 11:27:11 +0000
commit083f6077077e7662db6aaf05f9952f85e60f1e47 (patch)
tree0a177f8b5ee8bd08468ab32ce5a692bf8edeb915
downloadaur-083f6077077e7662db6aaf05f9952f85e60f1e47.tar.gz
Init
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD22
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2d50e7e5189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hackernel
+ pkgdesc = Host Intrusion Detection and Prevention System
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://github.com/lanthora/hackernel
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = go
+ makedepends = npm
+ makedepends = nodejs
+ makedepends = nlohmann-json
+ depends = dkms
+ depends = libnl
+ backup = etc/hackernel/telegram.yaml
+ backup = etc/hackernel/web.yaml
+ source = https://github.com/lanthora/hackernel/archive/refs/tags/v1.7.1.tar.gz
+ sha256sums = 4f2072288ad162fef5eeac0c9ce06e61060415cc4c38fd6738b2f27c2642d084
+
+pkgname = hackernel
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9f7fce52b2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=hackernel
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="Host Intrusion Detection and Prevention System"
+url="https://github.com/lanthora/hackernel"
+license=('GPL')
+arch=('x86_64' 'armv7h' 'aarch64')
+source=("https://github.com/lanthora/hackernel/archive/refs/tags/v$pkgver.tar.gz" )
+sha256sums=('4f2072288ad162fef5eeac0c9ce06e61060415cc4c38fd6738b2f27c2642d084')
+depends=('dkms' 'libnl')
+makedepends=('git' 'cmake' 'make' 'go' 'npm' 'nodejs' 'nlohmann-json')
+backup=('etc/hackernel/telegram.yaml' 'etc/hackernel/web.yaml')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make arch-build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" arch-install
+}