summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanthora2024-03-30 15:56:42 +0000
committerlanthora2024-03-30 15:56:42 +0000
commit324b999512aa4dded6e4309ce9d5c28302fd7f8b (patch)
tree494e6c0c1e0895a0fd36ce1541a11695a570bc56
parentae4f8238992604a35e73578595c5568e7a6ef660 (diff)
downloadaur-324b999512aa4dded6e4309ce9d5c28302fd7f8b.tar.gz
Update to v1.7.5
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16e33aeaf930..d623a6f1ea11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hackernel
pkgdesc = host intrusion detection and prevention system
- pkgver = 1.7.4
- pkgrel = 2
+ pkgver = 1.7.5
+ pkgrel = 1
url = https://github.com/lanthora/hackernel
arch = x86_64
arch = armv7h
@@ -15,9 +15,7 @@ pkgbase = hackernel
depends = libnl
backup = etc/hackernel/telegram.yaml
backup = etc/hackernel/web.yaml
- source = https://github.com/lanthora/hackernel/archive/refs/tags/v1.7.4.tar.gz
- source = https://patch-diff.githubusercontent.com/raw/lanthora/hackernel/pull/91.diff
- sha256sums = 6ff0a8098629fb75fa253c3657f7586a529727401b98053b329c14f31a715abd
- sha256sums = b61bf7487f9ab00bcd96fc060caa2d825dea1e637724f19ac7a9dce41ed802e2
+ source = https://github.com/lanthora/hackernel/archive/refs/tags/v1.7.5.tar.gz
+ sha256sums = fbcea470ffc414703e39c0898546c46908c227ba358056153566712cbe933076
pkgname = hackernel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..961853395291
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.zst
+*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index f8539f7215e8..35f35a76afca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
pkgname=hackernel
-pkgver=1.7.4
-pkgrel=2
+pkgver=1.7.5
+pkgrel=1
pkgdesc="host intrusion detection and prevention system"
url="https://github.com/lanthora/hackernel"
license=('GPL')
arch=('x86_64' 'armv7h' 'aarch64')
-source=(https://github.com/lanthora/hackernel/archive/refs/tags/v$pkgver.tar.gz
- https://patch-diff.githubusercontent.com/raw/lanthora/hackernel/pull/91.diff)
+source=(https://github.com/lanthora/hackernel/archive/refs/tags/v$pkgver.tar.gz)
-sha256sums=('6ff0a8098629fb75fa253c3657f7586a529727401b98053b329c14f31a715abd'
- 'b61bf7487f9ab00bcd96fc060caa2d825dea1e637724f19ac7a9dce41ed802e2')
+sha256sums=('fbcea470ffc414703e39c0898546c46908c227ba358056153566712cbe933076')
depends=('dkms' 'libnl')
makedepends=('cmake' 'make' 'go' 'nlohmann-json')
@@ -17,7 +15,6 @@ backup=('etc/hackernel/telegram.yaml' 'etc/hackernel/web.yaml')
build() {
cd "$pkgname-$pkgver"
- patch -Np1 < ../91.diff
make arch-build
}