summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanthora2023-12-27 01:41:12 +0000
committerlanthora2023-12-27 01:41:12 +0000
commitae4f8238992604a35e73578595c5568e7a6ef660 (patch)
treee38dc3e582d5b5f933116b26b11ab9ed3d5b8b33
parentf0298f652a62e34ebd8530f584c9c8b6d324effd (diff)
downloadaur-ae4f8238992604a35e73578595c5568e7a6ef660.tar.gz
remove webui
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4fb091f385d..16e33aeaf930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hackernel
pkgdesc = host intrusion detection and prevention system
pkgver = 1.7.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lanthora/hackernel
arch = x86_64
arch = armv7h
@@ -11,13 +11,13 @@ pkgbase = hackernel
makedepends = make
makedepends = go
makedepends = nlohmann-json
- makedepends = nodejs
- makedepends = npm
depends = dkms
depends = libnl
backup = etc/hackernel/telegram.yaml
backup = etc/hackernel/web.yaml
source = https://github.com/lanthora/hackernel/archive/refs/tags/v1.7.4.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/lanthora/hackernel/pull/91.diff
sha256sums = 6ff0a8098629fb75fa253c3657f7586a529727401b98053b329c14f31a715abd
+ sha256sums = b61bf7487f9ab00bcd96fc060caa2d825dea1e637724f19ac7a9dce41ed802e2
pkgname = hackernel
diff --git a/PKGBUILD b/PKGBUILD
index bcba696d624a..f8539f7215e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
pkgname=hackernel
pkgver=1.7.4
-pkgrel=1
+pkgrel=2
pkgdesc="host intrusion detection and prevention system"
url="https://github.com/lanthora/hackernel"
license=('GPL')
arch=('x86_64' 'armv7h' 'aarch64')
-source=("https://github.com/lanthora/hackernel/archive/refs/tags/v$pkgver.tar.gz" )
-sha256sums=('6ff0a8098629fb75fa253c3657f7586a529727401b98053b329c14f31a715abd')
+source=(https://github.com/lanthora/hackernel/archive/refs/tags/v$pkgver.tar.gz
+ https://patch-diff.githubusercontent.com/raw/lanthora/hackernel/pull/91.diff)
+
+sha256sums=('6ff0a8098629fb75fa253c3657f7586a529727401b98053b329c14f31a715abd'
+ 'b61bf7487f9ab00bcd96fc060caa2d825dea1e637724f19ac7a9dce41ed802e2')
+
depends=('dkms' 'libnl')
-makedepends=('cmake' 'make' 'go' 'nlohmann-json' 'nodejs' 'npm')
+makedepends=('cmake' 'make' 'go' 'nlohmann-json')
backup=('etc/hackernel/telegram.yaml' 'etc/hackernel/web.yaml')
build() {
cd "$pkgname-$pkgver"
+ patch -Np1 < ../91.diff
make arch-build
}