summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2023-04-23 12:31:26 +0200
committerFrancesco Minnocci2023-04-23 12:31:26 +0200
commit35229ac2563580018411392057473f6ab92660f3 (patch)
tree175530f4c8479979b472c86401f217daca8bf41f
parenta99606b4b22abb80c7cee6a5716d60bdcd9ba261 (diff)
downloadaur-35229ac2563580018411392057473f6ab92660f3.tar.gz
Update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1750b30604b..c846bdecebc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = hackernews_tui
pkgdesc = A Terminal UI to browse hacker news.
pkgver = 0.12.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aome510/hackernews-TUI
arch = x86_64
license = MIT
makedepends = cargo
optdepends = mercury-parser: to view articles directly in the terminal
+ options = !lto
source = hackernews_tui-0.12.0.tar.gz::https://github.com/aome510/hackernews-TUI/archive/v0.12.0.tar.gz
sha512sums = dc2082f209cce891f068b0459f4fb2205013b3481e4eea6302a9cce23b105ede497ae3e5ead775fd8125e28f21a917b5d517b38436b5b3cb804cd388f50caebb
diff --git a/PKGBUILD b/PKGBUILD
index 3b88e2300093..a3048fbc96c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=hackernews_tui
_gitname=hackernews-TUI
pkgver=0.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Terminal UI to browse hacker news."
arch=("x86_64")
url="https://github.com/aome510/hackernews-TUI"
@@ -12,6 +12,8 @@ makedepends=('cargo')
optdepends=('mercury-parser: to view articles directly in the terminal')
source=("$pkgname-$pkgver.tar.gz::https://github.com/aome510/hackernews-TUI/archive/v$pkgver.tar.gz")
sha512sums=('dc2082f209cce891f068b0459f4fb2205013b3481e4eea6302a9cce23b105ede497ae3e5ead775fd8125e28f21a917b5d517b38436b5b3cb804cd388f50caebb')
+# disable LTO until ring can be built with it: https://github.com/briansmith/ring/issues/1444
+options=(!lto)
build() {
cd "${_gitname}-$pkgver"
@@ -30,5 +32,7 @@ package() {
install -Dm755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.md" "doc/config.md"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/examples" "examples/hn-tui.toml"
}
# vim:set ts=2 sw=2 et: