summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcropinghigh2022-03-27 14:50:11 +0300
committercropinghigh2022-03-27 14:50:11 +0300
commitecbb35ad92a53a9a52114bf6dc9af8be05862345 (patch)
treefb94deb5a9a4c5daace59b8d8022ed9181246c5f
parentf652272a3cf58b98db80a91dd34fa5791583e107 (diff)
downloadaur-ecbb35ad92a53a9a52114bf6dc9af8be05862345.tar.gz
update version code + git protocol
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 492c3816094f..06b4633070bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hacktv-git
pkgdesc = Analogue TV transmitter for the HackRF
- pkgver = 779a072
+ pkgver = r286.d7d37f4
pkgrel = 1
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = hacktv-git
depends = soapysdr
provides = hacktv
conflicts = hacktv
- source = git://github.com/fsphil/hacktv
+ source = git+https://github.com/fsphil/hacktv
md5sums = SKIP
pkgname = hacktv-git
diff --git a/PKGBUILD b/PKGBUILD
index f74773c59a06..4fdcc0d4b764 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: cropinghigh <joinmark60@gmail.com>
# Author: fsphil
pkgname=hacktv-git
-pkgver="779a072"
+pkgver=r286.d7d37f4
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Analogue TV transmitter for the HackRF"
@@ -11,12 +11,12 @@ depends=('hackrf' 'ffmpeg' 'soapysdr')
makedepends=('make' 'git')
provides=('hacktv')
conflicts=('hacktv')
-source=("git://github.com/fsphil/hacktv")
+source=("git+https://github.com/fsphil/hacktv")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/hacktv"
- git describe --tags --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {