summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-19 00:05:04 +0300
committerorhun2020-11-19 00:05:04 +0300
commitf3f326a6e85984fda0c33332012fee7d598c2937 (patch)
tree1a8fc5c9394eb96d790d09cc04f711e972dcaa4a
parent863adfb33cd98258e6ba0696c984285d56a46dff (diff)
downloadaur-f3f326a6e85984fda0c33332012fee7d598c2937.tar.gz
upgpkg: hadlock 1.1.6-1
upstream release Update PKGBUILD about --locked flag and rust dependency
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8621d62c51e..a8ef91fc0778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = hadlock
url = https://github.com/AdaShoelace/hadlock
arch = x86_64
license = MIT
- makedepends = cargo
+ makedepends = rust
depends = dbus
depends = libxinerama
source = hadlock-1.1.6.tar.gz::https://github.com/AdaShoelace/hadlock/archive/v1.1.6.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index bcbb4a97d4ca..c8b05765f70b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,14 @@ arch=('x86_64')
url="https://github.com/AdaShoelace/hadlock"
license=('MIT')
depends=('dbus' 'libxinerama')
-makedepends=('cargo')
+makedepends=('rust')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('ed7efb50410f75398b4ecf963e19ca115ba267501d4759f5754ee561c2da59610c8818f1575ab603f1a9c1112cc921d08f0115c4e02b6488b13a3cb5598f4ac1')
build() {
cd "$pkgname-$pkgver"
+ # TODO: Use `--locked` flag for reproducibility.
+ # Tracking issue: https://github.com/AdaShoelace/hadlock/issues/63
cargo build --release --all-features
}