summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-09-10 02:32:39 +0300
committerorhun2020-09-10 03:04:03 +0300
commit13c6bb652759a608715e291a0a5ae40d609852a8 (patch)
tree84559b395be225aa670fd5879afa6fb738c90a34
downloadaur-13c6bb652759a608715e291a0a5ae40d609852a8.tar.gz
Initial upload: hadlock-git 1.1.6.r0.gdee5d59-1
Initial upload: hadlock-git 1.1.6.r0.gdee5d59-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fd137a16843
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hadlock-git
+ pkgdesc = X window manager (git)
+ pkgver = 1.1.6.r0.gdee5d59
+ pkgrel = 1
+ url = https://github.com/AdaShoelace/hadlock
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ depends = dbus
+ depends = libxinerama
+ conflicts = hadlock-git
+ conflicts = hadlock-git-bin
+ source = git+https://github.com/AdaShoelace/hadlock
+ sha512sums = SKIP
+
+pkgname = hadlock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c0f500a9f22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=hadlock-git
+pkgver=1.1.6.r0.gdee5d59
+pkgrel=1
+pkgdesc="X window manager (git)"
+arch=('x86_64')
+url="https://github.com/AdaShoelace/hadlock"
+license=('MIT')
+depends=('dbus' 'libxinerama')
+makedepends=('git' 'cargo')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-bin")
+source=("git+$url")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release --all-features
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --release
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+}