summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-08-15 11:11:13 +0200
committerCarsten Teibes2015-08-23 02:20:10 +0200
commit1db815fe33f769c711cf8844c81c73934daf9800 (patch)
treef5c568dc400b1a6c7b7d19a06b434eafa5b04a37
downloadaur-1db815fe33f769c711cf8844c81c73934daf9800.tar.gz
[add] haguichi 1.3.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--haguichi.install16
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4beabd84068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haguichi
+ pkgdesc = Provides a user friendly GUI to control the Hamachi client on Linux
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://www.haguichi.net
+ install = haguichi.install
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv7h
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = gtk3
+ depends = libnotify
+ depends = logmein-hamachi
+ source = http://launchpad.net/haguichi/1.3/1.3.0/+download/haguichi-1.3.0.tar.xz
+ sha256sums = 6345802556d96ac0f49e7d7fc89867b52a6d737df21b525c38e3f59fa2fe8c0d
+
+pkgname = haguichi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a6a33baf51a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=haguichi
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Provides a user friendly GUI to control the Hamachi client on Linux"
+arch=('x86_64' 'i686' 'arm' 'armv7h')
+url="http://www.haguichi.net"
+license=('GPL3')
+depends=('gtk3' 'libnotify' 'logmein-hamachi')
+makedepends=('cmake' 'vala')
+install=$pkgname.install
+source=("http://launchpad.net/$pkgname/${pkgver%.*}/$pkgver/+download/$pkgname-$pkgver.tar.xz")
+sha256sums=('6345802556d96ac0f49e7d7fc89867b52a6d737df21b525c38e3f59fa2fe8c0d')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ rm -rf build
+ mkdir build
+}
+
+build() {
+ cd $pkgname-$pkgver/build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DICON_UPDATE=OFF -DGSETTINGS_COMPILE=OFF
+ make
+}
+
+package() {
+ make -C $pkgname-$pkgver/build DESTDIR="$pkgdir" install
+}
diff --git a/haguichi.install b/haguichi.install
new file mode 100644
index 000000000000..4edac60259d5
--- /dev/null
+++ b/haguichi.install
@@ -0,0 +1,16 @@
+
+post_install() {
+ _themes="hicolor Adwaita ubuntu-mono-dark ubuntu-mono-light"
+ for _t in $_themes; do
+ gtk-update-icon-cache -q -t -f usr/share/icons/$_t
+ done
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}