summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Brandt2017-09-27 19:18:29 +0200
committerStephen Brandt2017-09-27 19:18:29 +0200
commit236c2001c4f7440ff56a8edf39f22f9f10baf3a7 (patch)
tree6869648f4fb5dcb1a0c5d6228a5115491b0cc7dd
parente69b510912bea2e341ef6d03d2be8a09240fe449 (diff)
downloadaur-236c2001c4f7440ff56a8edf39f22f9f10baf3a7.tar.gz
[upd] 1.3.7→1.3.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d9f0660f1d5..22b360d10c1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = haguichi
pkgdesc = Provides a user friendly GUI to control the Hamachi client on Linux
- pkgver = 1.3.7
+ pkgver = 1.3.8
pkgrel = 1
- url = http://www.haguichi.net
+ url = https://www.haguichi.net
arch = x86_64
arch = i686
arch = arm
+ arch = armv6h
arch = armv7h
license = GPL3
- makedepends = cmake
+ makedepends = meson
makedepends = vala
depends = gtk3
depends = libnotify
depends = logmein-hamachi
- source = http://launchpad.net/haguichi/1.3/1.3.7/+download/haguichi-1.3.7.tar.xz
- sha256sums = e769b81a8de9932ea42d0a21431e6c1440ef638472d68ab2d5bebab9c728cfbc
+ source = http://launchpad.net/haguichi/1.3/1.3.8/+download/haguichi-1.3.8.tar.xz
+ sha256sums = b5834b1ed4a9e578e3f0b98ff27db7ca9e458cd2cf0d810bbd470bfbfe20141e
pkgname = haguichi
diff --git a/PKGBUILD b/PKGBUILD
index 66e8c293d4fd..611b3f843e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Stephen Brandt <stephen@stephenbrandt.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=haguichi
-pkgver=1.3.7
+pkgver=1.3.8
pkgrel=1
pkgdesc="Provides a user friendly GUI to control the Hamachi client on Linux"
-arch=('x86_64' 'i686' 'arm' 'armv7h')
-url="http://www.haguichi.net"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+url="https://www.haguichi.net"
license=('GPL3')
depends=('gtk3' 'libnotify' 'logmein-hamachi')
-makedepends=('cmake' 'vala')
+makedepends=('meson' 'vala')
source=("http://launchpad.net/$pkgname/${pkgver%.*}/$pkgver/+download/$pkgname-$pkgver.tar.xz")
-sha256sums=('e769b81a8de9932ea42d0a21431e6c1440ef638472d68ab2d5bebab9c728cfbc')
+sha256sums=('b5834b1ed4a9e578e3f0b98ff27db7ca9e458cd2cf0d810bbd470bfbfe20141e')
prepare() {
cd $pkgname-$pkgver
@@ -22,10 +23,10 @@ prepare() {
build() {
cd $pkgname-$pkgver/build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DICON_UPDATE=OFF -DGSETTINGS_COMPILE=OFF
- make
+ meson ..
+ ninja
}
package() {
- make -C $pkgname-$pkgver/build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C $pkgname-$pkgver/build install
}