summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvery2015-06-08 19:52:36 -0500
committerAvery2015-06-08 19:52:36 -0500
commit567f9cc98fe95ba6ebda71d6347c8833718037d0 (patch)
treef10c4441a17c358774fe45b6fb2e55a524402d75
downloadaur-567f9cc98fe95ba6ebda71d6347c8833718037d0.tar.gz
Initial Import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38b16a2b23c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hal-flash-git
+ pkgdesc = A libhal stub library forwarding to UDisks2 for flash to play DRM content
+ pkgver = 0.3.0
+ pkgrel = 2
+ url = https://github.com/cshorler/hal-flash
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = autoconf>=2.60
+ makedepends = pkgconfig
+ makedepends = git
+ depends = udisks2
+ depends = dbus
+ provides = hal=0.5.15
+ conflicts = hal
+ source = hal-flash-git::git+http://github.com/cshorler/hal-flash.git
+ md5sums = SKIP
+
+pkgname = hal-flash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd73055bac7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Freonmonkey <freonmonkey at gmail dot com>
+#
+# The git version of hal-flash
+#
+# This project provides a stub libhal that uses UDisks and meets the needs
+# for playing Flash DRM content without a full HAL installation and daemon.
+
+pkgname=hal-flash-git
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="A libhal stub library forwarding to UDisks2 for flash to play DRM content"
+arch=('i686' 'x86_64')
+url="https://github.com/cshorler/hal-flash"
+license=('GPL2')
+groups=()
+depends=('udisks2' 'dbus')
+makedepends=('autoconf>=2.60' 'pkgconfig' 'git')
+provides=('hal=0.5.15')
+conflicts=('hal')
+source=("$pkgname"::'git+http://github.com/cshorler/hal-flash.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ msg2 "Running configuration to determine package version..."
+ autoreconf -i >/dev/null
+ ./configure --version | head -n1 | sed -E 's/.* configure (.+)/\1/'
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ ./configure --prefix=/usr --enable-static=no
+
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ # Install built files into the package
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+
+ # Skip copying COPYING to LICENSE since it's just GPL2
+}
+