summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheguy2020-04-27 20:14:05 +0200
committertheguy2020-04-27 20:14:05 +0200
commit79dad9c70dc2487a885ecb3530081ceef358f167 (patch)
treefad00705273670d59b996fc5d83f90a3573022bc
downloadaur-79dad9c70dc2487a885ecb3530081ceef358f167.tar.gz
initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD36
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51b4b41470e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = hal-git
+ pkgdesc = The Hardware Analyzer for Hardware Reversing from emsec. (git version)
+ pkgver = v2.0.0.r139.gc906c8fc
+ pkgrel = 1
+ url = https://github.com/emsec/hal
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = ccache
+ depends = lcov
+ depends = gcovr
+ depends = doxygen
+ depends = boost
+ depends = qt5-svg
+ depends = libsodium
+ depends = igraph
+ depends = ninja
+ depends = rapidjson
+ depends = spdlog
+ depends = python-sphinx
+ depends = python-sphinx_rtd_theme
+ depends = python-jedi
+ depends = python-pip
+ depends = python-dateutil
+ depends = pybind11
+ optdepends = graphviz: for documentation
+ source = hal-git::git+https://github.com/emsec/hal.git
+ md5sums = SKIP
+
+pkgname = hal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6552336a7826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+pkgname=hal-git
+pkgver=v2.0.0.r139.gc906c8fc
+pkgrel=1
+pkgdesc='The Hardware Analyzer for Hardware Reversing from emsec. (git version)'
+arch=('x86_64')
+url='https://github.com/emsec/hal'
+license=('MIT')
+depends=('lcov' 'gcovr' 'doxygen' 'boost' 'qt5-svg' 'libsodium' 'igraph' 'ninja' 'rapidjson' 'spdlog' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-jedi' 'python-pip' 'python-dateutil' 'pybind11')
+optdepends=('graphviz: for documentation')
+makedepends=('git' 'cmake' 'ccache')
+source=("$pkgname::git+https://github.com/emsec/hal.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ sed -i 's:enable_cxx_compiler_flag_if_supported("-fcolor-diagnostics" "")::g' ./CMakeLists.txt
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+
+ mkdir -p build && cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir" install
+}