summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-10 20:55:50 -0600
committerBrian Bidulock2015-07-10 20:55:50 -0600
commit41e4f8946c0c9a91ab34beaa8e2b9d770f39abda (patch)
treee28a1cc28ae9e7b66c0a73c3a54a382862fa4ce1
downloadaur-41e4f8946c0c9a91ab34beaa8e2b9d770f39abda.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..275fe3ec7d49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hal-info
+ pkgdesc = Hardware Abstraction Layer information files
+ pkgver = 0.20091130
+ pkgrel = 3
+ url = http://www.freedesktop.org/wiki/Software/hal
+ arch = any
+ license = GPL
+ license = custom
+ options = !emptydirs
+ source = http://hal.freedesktop.org/releases/hal-info-20091130.tar.gz
+ md5sums = 34375489a02a00b250fdc0b280be11b8
+
+pkgname = hal-info
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8c8f63cd81e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=hal-info
+_date=20091130
+pkgver=0.${_date}
+pkgrel=3
+pkgdesc="Hardware Abstraction Layer information files"
+arch=(any)
+options=('!emptydirs')
+license=('GPL' 'custom')
+url="http://www.freedesktop.org/wiki/Software/hal"
+source=(http://hal.freedesktop.org/releases/hal-info-${_date}.tar.gz)
+md5sums=('34375489a02a00b250fdc0b280be11b8')
+
+build() {
+ cd "${srcdir}/${pkgname}-${_date}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-killswitch-dell-wlan=no \
+ --enable-killswitch-dell-bluetooth=no \
+ --enable-killswitch-dell-wwan=no
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${_date}"
+ make DESTDIR=${pkgdir} install
+}