summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-05-10 00:15:06 -0700
committerBuildTools2016-05-10 00:15:06 -0700
commitcc3e421f6afb9295b21d2d52987ba353b2aae096 (patch)
treede0c626c41d4e4a94cd40e598776151c903fa2ad
downloadaur-cc3e421f6afb9295b21d2d52987ba353b2aae096.tar.gz
init
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
-rw-r--r--halcyon.sh2
-rw-r--r--hc-database.sh2
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f0a1cd67476
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue May 10 07:14:53 UTC 2016
+pkgbase = halcyon
+ pkgdesc = InWorldz Halcyon 3d virtual reality world simulator
+ pkgver = 0.9.22.5917
+ pkgrel = 1
+ url = https://github.com/InWorldz/halcyon
+ arch = any
+ license = BSD
+ makedepends = doxygen
+ depends = mono
+ depends = mariadb
+ depends = sqlite
+ depends = whip-server
+ provides = opensimulator
+ source = https://github.com/InWorldz/halcyon/archive/v0.9.22.5917.tar.gz
+ source = halcyon.sh
+ source = hc-database.sh
+ md5sums = 1e5bf12cc2697d6ae234c5537481ce5a
+ md5sums = 86977d028c882ee1e9615f4b8d1a68e6
+ md5sums = ee63724ab4ed7ba836ea6205689b0029
+
+pkgname = halcyon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25cca9a92b37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb7234c1eaa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+pkgname=halcyon
+pkgver=0.9.22.5917
+pkgrel=1
+pkgdesc="InWorldz Halcyon 3d virtual reality world simulator"
+arch=(any)
+url="https://github.com/InWorldz/$pkgname"
+license=("BSD")
+depends=(mono mariadb sqlite whip-server)
+makedepends=(doxygen)
+provides=(opensimulator)
+source=("https://github.com/InWorldz/$pkgname/archive/v$pkgver.tar.gz"
+"$pkgname.sh"
+"hc-database.sh")
+md5sums=('1e5bf12cc2697d6ae234c5537481ce5a'
+ '86977d028c882ee1e9615f4b8d1a68e6'
+ 'ee63724ab4ed7ba836ea6205689b0029')
+
+build() {
+ cd $pkgname-$pkgver
+ ./runprebuild.sh
+ xbuild Halcyon.sln
+ doxygen doc/doxygen.conf
+}
+
+package() {
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname"
+ install -m755 hc-database.sh "$pkgdir/usr/bin/hc-database"
+ cd $pkgname-$pkgver
+ mkdir -p "$pkgdir/srv/inworldz"
+ cp -r bin/* "$pkgdir/srv/inworldz/"
+ chmod -R 644 "$pkgdir/srv/inworldz"
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp -r share/* "$pkgdir/usr/share/$pkgname/"
+ chmod -R 644 "$pkgdir/usr/share/$pkgname"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname/bot LSL Functions"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname/html"
+ cp -r "doc/bot LSL Functions/"* "$pkgdir/usr/share/doc/$pkgname/bot LSL Functions/"
+ cp -r html/* "$pkgdir/usr/share/doc/$pkgname/html/"
+ chmod -R 644 "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgdir/srv/inworldz"
+ rm PhysX3*.dll
+ rm Prebuild.exe
+ rm aperture.exe
+ rm cg*.dll
+ rm cudart64_32_16.dll
+ rm glut32.dll
+ rm libapr*.dll
+ rm libbulletnet.dll
+ rm libcurl.dll
+ rm libdb44d.dll
+ rm libeay32.dll
+ rm *.dylib
+ rm *.so.*
+ rm libssh2.dll
+ rm msvc*.dll
+ rm openjpeg*.dll
+ rm sqlite3.dll
+ rm ssleay32.dll
+ rm zlib1.dll
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/halcyon.sh b/halcyon.sh
new file mode 100644
index 000000000000..659084e6b86e
--- /dev/null
+++ b/halcyon.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+mono /srv/inworldz/Halcyon.exe $@
diff --git a/hc-database.sh b/hc-database.sh
new file mode 100644
index 000000000000..61f27874b8e3
--- /dev/null
+++ b/hc-database.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+mono /srv/inworldz/hc-database.exe $@