summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-03-15 12:01:08 +0530
committertxtsd2024-03-15 12:01:08 +0530
commitd8db2691d676f103fef7a332f835bb16fb43d797 (patch)
tree55e24a538f1432d3f12ec3542c77889954a3ab0f
downloadaur-d8db2691d676f103fef7a332f835bb16fb43d797.tar.gz
upgpkg: halloy-bin 2024.3-1
Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32b06569769d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = halloy-bin
+ pkgdesc = An open-source IRC client written in Rust, with the Iced GUI library
+ pkgver = 2024.3
+ pkgrel = 1
+ url = https://github.com/squidowl/halloy
+ arch = x86_64
+ license = GPL-3.0-or-later
+ depends = openssl
+ depends = glibc
+ depends = gcc-libs
+ depends = hicolor-icon-theme
+ provides = halloy
+ conflicts = halloy
+ source = https://github.com/squidowl/halloy/releases/download/2024.3/halloy-2024.3-x86_64-linux.tar.gz
+ sha256sums = b6f8bee1e62a3fa6a0126a5124d113a1ede7f51c52bea6c161697de40461a77e
+
+pkgname = halloy-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f9f94123be37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d585a1270bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=halloy-bin
+_pkgname="${pkgname/-bin}"
+pkgver=2024.3
+pkgrel=1
+pkgdesc='An open-source IRC client written in Rust, with the Iced GUI library'
+arch=('x86_64')
+url='https://github.com/squidowl/halloy'
+license=('GPL-3.0-or-later')
+depends=('openssl' 'glibc' 'gcc-libs' 'hicolor-icon-theme')
+provides=('halloy')
+conflicts=('halloy')
+source=("${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}-x86_64-linux.tar.gz")
+sha256sums=('b6f8bee1e62a3fa6a0126a5124d113a1ede7f51c52bea6c161697de40461a77e')
+
+package() {
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm644 "org.squidowl.${_pkgname}.appdata.xml" -t "${pkgdir}/usr/share/appdata/metainfo"
+ install -Dm644 "org.squidowl.${_pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "org.squidowl.${_pkgname}.png" -t "${pkgdir}/usr/share/icons/hicolor/128x128/apps"
+}