summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElijah Gregg2021-05-21 13:55:14 -0600
committerElijah Gregg2021-05-21 13:55:14 -0600
commit5fc371e955fb2a3f42e1a2763cba651e876b6ab9 (patch)
tree97007191066d4f3dfcb1ba1e0e2cccc8c216c902
downloadaur-5fc371e955fb2a3f42e1a2763cba651e876b6ab9.tar.gz
Create halmak-git
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..042c6616eb84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = halmak-git
+ pkgdesc = The final version of the AI designed keyboard layout
+ pkgver = 2.1.0.r17.g4d2a620
+ pkgrel = 1
+ url = https://github.com/MadRabbit/halmak
+ arch = x86_64
+ license = MIT
+ depends = libxkbcommon
+ provides = halmak
+ conflicts = halmak
+ source = git+https://github.com/MadRabbit/halmak.git
+ md5sums = SKIP
+
+pkgname = halmak-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7173dfc00c09
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.zst
+pkg/
+src/
+halmak/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0714acdd624d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Elijah Gregg <lovetocode999@tilde.team>
+pkgname=halmak-git
+pkgver=2.1.0.r17.g4d2a620
+pkgrel=1
+pkgdesc="The final version of the AI designed keyboard layout"
+arch=("x86_64")
+url="https://github.com/MadRabbit/halmak"
+license=("MIT")
+depends=("libxkbcommon")
+provides=("halmak")
+conflicts=("halmak")
+source=("git+https://github.com/MadRabbit/halmak.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/halmak"
+
+ _tag=$(git tag --sort=v:refname | tail -n1)
+ printf '%s.r%s.g%s' "${_tag#v}" "$(git rev-list "$_tag"..HEAD --count)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/halmak"
+ mkdir -p "${pkgdir}/usr/share/X11/xkb"
+ cp -R "linux/symbols" "${pkgdir}/usr/share/X11/xkb"
+ rm "${pkgdir}/usr/share/X11/xkb/symbols/halmak"
+ mv "${pkgdir}/usr/share/X11/xkb/symbols/halmak_no_qwerty" "${pkgdir}/usr/share/X11/xkb/symbols/halmak"
+}