summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaze X2017-03-01 10:31:45 +0100
committerMaze X2017-03-01 10:31:45 +0100
commit5f0a33b5693c0698527b86c091419e6874fb0f59 (patch)
tree5d5d153fd3d5b85b420e7d7f25038da0b83c7851
parentf4ce2b7b61f4dd49f41c436b12cd20f64ba74595 (diff)
downloadaur-5f0a33b5693c0698527b86c091419e6874fb0f59.tar.gz
Updated to 3.1
Not that this now builds against Python 3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
-rw-r--r--hamlib.ChangeLog.markdown6
3 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9532641d408..3e294e6b8fe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = hamlib
pkgdesc = Ham radio equipment control libraries
- pkgver = 3.0.1
+ pkgver = 3.1
pkgrel = 1
url = http://hamlib.org
- changelog = hamlib.ChangeLog.markdown
arch = i686
arch = x86_64
arch = armv6h
@@ -14,15 +13,15 @@ pkgbase = hamlib
makedepends = swig
makedepends = pkgconfig
depends = perl
- depends = python2
+ depends = python
depends = tcl
depends = libxml2
depends = libusb-compat
depends = libtool
options = !emptydirs
- source = http://downloads.sourceforge.net/project/hamlib/hamlib/3.0.1/hamlib-3.0.1.tar.gz
- sha1sums = 2263b77775b6bf86e0c9b0ac22d4df60119dfffe
- sha256sums = 3fec97ea326d02aa8f35834c4af34194a3f544e6212f391397d788c566b44e32
+ source = http://downloads.sourceforge.net/project/hamlib/hamlib/3.1/hamlib-3.1.tar.gz
+ sha256sums = 682304c3e88ff6ccfd6a5fc28b33bcc95d2d0a54321973fef015ff62570c994e
+ sha512sums = befc5c407379e30711bde2affb9c191add6dbb04a36c1309f8771170cf04156c48609a094775638036282e085de6c78d09ef8d2760d69c595471e16e985e0885
pkgname = hamlib
diff --git a/PKGBUILD b/PKGBUILD
index ca767ed6e51a..8303f64126f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,21 @@
# Contributor: Vitaliy Berdinskikh <ur6lad@archlinux.org.ua>
pkgname=hamlib
-pkgver=3.0.1
+pkgver=3.1
pkgrel=1
pkgdesc="Ham radio equipment control libraries"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://hamlib.org"
license=('GPL' 'LGPL')
-depends=('perl' 'python2' 'tcl' 'libxml2' 'libusb-compat' 'libtool')
+depends=('perl' 'python' 'tcl' 'libxml2' 'libusb-compat' 'libtool')
makedepends=('libtool' 'swig' 'pkgconfig')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
options=('!emptydirs')
-changelog=${pkgname}.ChangeLog.markdown
+sha256sums=('682304c3e88ff6ccfd6a5fc28b33bcc95d2d0a54321973fef015ff62570c994e')
+sha512sums=('befc5c407379e30711bde2affb9c191add6dbb04a36c1309f8771170cf04156c48609a094775638036282e085de6c78d09ef8d2760d69c595471e16e985e0885')
build() {
- export PYTHON=/usr/bin/python2
-
cd $srcdir
-
cd $pkgname-$pkgver
./configure \
@@ -46,5 +44,3 @@ package() {
/usr/bin/find $pkgdir -name '.packlist' -delete
/usr/bin/find $pkgdir -name '*.pod' -delete
}
-sha1sums=('2263b77775b6bf86e0c9b0ac22d4df60119dfffe')
-sha256sums=('3fec97ea326d02aa8f35834c4af34194a3f544e6212f391397d788c566b44e32')
diff --git a/hamlib.ChangeLog.markdown b/hamlib.ChangeLog.markdown
deleted file mode 100644
index 7438214bcc8a..000000000000
--- a/hamlib.ChangeLog.markdown
+++ /dev/null
@@ -1,6 +0,0 @@
-1.2.12-2
----
-_Fri Mar 11 23:45:44 EET 2011 @948 /Internet Time/_
-
-* Set of **python**'s version as 2.7
-* Fix **configure**: piece of checking python extra libraries