summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-06-11 08:46:23 +0200
committerCarsten Feuls2015-06-11 08:46:23 +0200
commit24779940c64056b5be2b53936d2279ef1d7206b7 (patch)
tree049142ff21709122e4a66ebb9261e8bcdacb47ab
downloadaur-24779940c64056b5be2b53936d2279ef1d7206b7.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD54
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..309423e314f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = hamlib-git
+ pkgdesc = Ham radio equipment control libraries
+ pkgver = 3f1bde0
+ pkgrel = 1
+ url = http://hamlib.org
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ license = LGPL
+ makedepends = libtool
+ makedepends = swig
+ depends = perl
+ depends = python2
+ depends = tcl
+ depends = libxml2
+ depends = libusb
+ provides = hamlib
+ conflicts = hamlib
+ options = !emptydirs
+ source = hamlib-git::git+git://git.code.sf.net/p/hamlib/code
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = hamlib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ab9cafdac95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Carsten Feuls <archlinux at carstenfeuls dot de>
+
+pkgname=hamlib-git
+pkgver=3f1bde0
+pkgrel=1
+pkgdesc="Ham radio equipment control libraries"
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="http://hamlib.org"
+license=('GPL' 'LGPL')
+depends=('perl' 'python2' 'tcl' 'libxml2' 'libusb')
+makedepends=('libtool' 'swig')
+source=('hamlib-git::git+git://git.code.sf.net/p/hamlib/code')
+options=('!emptydirs')
+conflicts=('hamlib')
+provides=('hamlib')
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ export PYTHON=/usr/bin/python2
+
+ cd ${srcdir}/${pkgname}
+ ./autogen.sh \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --with-perl-binding \
+ --with-python-binding \
+ --with-xml-support \
+ --with-tcl-binding
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ make DESTDIR=$pkgdir install
+
+ # fix perl module location
+ cd $pkgdir/usr/lib/perl5/site_perl/
+ mkdir -p current/
+ mv auto current
+ mv Hamlib.pm current
+ rm perltest.pl
+
+ /usr/bin/find $pkgdir -name '.packlist' -delete
+ /usr/bin/find $pkgdir -name '*.pod' -delete
+}
+